Download it now!
Bug 107342 - Horizontal alignment of shapes doesnt function
Summary: Horizontal alignment of shapes doesnt function
Status: RESOLVED DUPLICATE of bug 90850
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Unify-Across-Apps
  Show dependency treegraph
 
Reported: 2017-04-21 21:52 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 21:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-04-21 21:52:30 UTC
Steps:
1) Open Writer
2) Insert a shape
3) Notice that the alignment group button in the Drawing Object Properties dialog is disabled
4) Only when you change the anchor to 'As Character' does the button enable, but only the vertical alignment buttons are enabled

The UNO commands .uno:ObjectAlignLeft, .uno:AlignCenter, and .uno:ObjectAlignRight need to be modified to get them to work with shapes, like they do with images, charts, and frames.

Version: 5.4.0.0.alpha0+
Build ID: 04edc5c796c1b96e5228d0c1fcf73bcf52465b66
CPU threads: 2; OS: Linux 3.19; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-15_03:25:45
Locale: en-US (en_US.UTF-8); Calc: group

@Gulsah: Interested in taking this one?
Comment 1 Buovjaga 2017-04-28 16:15:07 UTC
Repro.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 9348b322a5c230dfcc2231661b73e480b130fcd9
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 28th 2016
Comment 2 Maxim Monastirsky 2017-04-30 09:31:50 UTC
(In reply to Yousuf Philips (jay) from comment #0)
> 4) Only when you change the anchor to 'As Character' does the button enable,
> but only the vertical alignment buttons are enabled
I don't understand. If a shape is considered as a character, how can it be aligned horizontally? Do you want it to move to a different anchor point inside the text?

> The UNO commands .uno:ObjectAlignLeft, .uno:AlignCenter, and
> .uno:ObjectAlignRight need to be modified to get them to work with shapes,
> like they do with images, charts, and frames.
They do not work for me for images, charts, and frames (but they do work for shapes if you select two shapes).
Comment 3 Yousuf Philips (jay) (retired) 2017-04-30 10:42:14 UTC
(In reply to Maxim Monastirsky from comment #2)
> I don't understand. If a shape is considered as a character, how can it be
> aligned horizontally? Do you want it to move to a different anchor point
> inside the text?

Was just stating when the group button was enabled, but anchored as a character you couldnt align it horizontally.

> They do not work for me for images, charts, and frames (but they do work for
> shapes if you select two shapes).

Sorry my bad. The horizontal alignment UNO commands for images, charts and frames is different (.uno:AlignLeft, .uno:AlignHorizontalCenter, .uno:AlignRight). So shape alignment UNO commands work in Draw/Impress.
Comment 4 Maxim Monastirsky 2017-10-22 21:22:41 UTC

*** This bug has been marked as a duplicate of bug 90850 ***