Bug Hunting Session
Bug 107402 - FILESAVE - Export to PDF of a BASE form does not handle LONGVARCHAR fields in multiline controls correctly
Summary: FILESAVE - Export to PDF of a BASE form does not handle LONGVARCHAR fields in...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-24 21:12 UTC by Alan Wheeler
Modified: 2018-05-14 14:24 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Sample database file (12.97 KB, application/vnd.sun.xml.base)
2017-04-27 11:45 UTC, Alan Wheeler
Details
Screen shot of filled-in form (45.97 KB, image/jpeg)
2017-04-27 11:46 UTC, Alan Wheeler
Details
Exported PDF file showing blank dates (13.43 KB, application/pdf)
2017-04-27 11:47 UTC, Alan Wheeler
Details
Exported PDF file showing partially blank LONGVARCHAR field (22.20 KB, application/pdf)
2017-04-27 11:49 UTC, Alan Wheeler
Details
Screenshot with master 5.4.0 (35.49 KB, image/png)
2017-05-09 08:05 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Wheeler 2017-04-24 21:12:39 UTC
To demonstrate the problems :-

Create a database with one table and one form

Configure the table with five fields (all options set to default) :-
Date1 - Key field of type Date [DATE]
Text1 - Field of type Text [VARCHAR]
Date2 - Field of type Date [DATE]
Date3 - Field of type Date [DATE]
Memo1 - Field of type Memo [LONGVARCHAR]

Configure the form to show all five fields

Use the form to input "01/01/81" into all five fields (enter six such lines in Memo1) and save it

Problem 1 :-
Display the form and export it as a PDF file, every checkbox on the "General" panel unchecked except "Create PDF Form" and "View PDF after export", with "PDF" selected as the "Submit Format"

Expected result is that the displayed (and saved) PDF should show all fields as "01/01/81" (six such lines in Memo1)

My first actual result was that Date1 was blank, Text1 was shown as "01/01/81", Date2 was blank, Date3 was shown as "01/01/81" and Memo1 was shown as six lines of "01/01/81"

If I then exited from LibreOffice, restarted it, redisplayed the form and performed the same export to PDF, I got slightly different results - this time, only Text1 and Memo1 were shown correctly, but all three date fields were blank

ie. Actual results are unpredictable, but there is a definite problem somewhere with fields of type date

I only have release 5.3.2.2 available for testing. I may well be wrong, but I have the feeling that this problem may not have occurred on the release that was available early in 2016.

Problem 2 :-
If checkbox "Archive PDF/A-1a (ISO19005-1)" is checked when exporting the form as PDF, all dates are displayed correctly, but a white area is shown in Memo1, obscuring most of the text.
Comment 1 Alex Thurgood 2017-04-26 13:14:39 UTC
This is not IMO a Base problem, but a PDF export /printing problem - changing module accordingly.
Comment 2 Alex Thurgood 2017-04-26 13:26:00 UTC
Possible DUP of bug 61850
Comment 3 Alex Thurgood 2017-04-26 13:42:37 UTC
Also, the incorrect font support could be down to bug 50879, where it appears that the default font used for certain fields in forms is not always embedded.
Comment 4 Alex Thurgood 2017-04-26 13:44:37 UTC
@Alan : could you provide a sample PDF file showing the behaviour you report ?

Setting to NEEDINFO, pending receipt of requested information.
Comment 5 Alan Wheeler 2017-04-27 11:45:10 UTC
Created attachment 132897 [details]
Sample database file
Comment 6 Alan Wheeler 2017-04-27 11:46:14 UTC
Created attachment 132898 [details]
Screen shot of filled-in form
Comment 7 Alan Wheeler 2017-04-27 11:47:16 UTC
Created attachment 132899 [details]
Exported PDF file showing blank dates
Comment 8 Alan Wheeler 2017-04-27 11:49:38 UTC
Created attachment 132900 [details]
Exported PDF file showing partially blank LONGVARCHAR field
Comment 9 Alan Wheeler 2017-04-27 11:51:50 UTC
I also just noticed that, even when the LONGVARCHAR field is not partially blanked out on the exported PDF, it only shows 7 lines whereas the form shows 8 lines. I would also suspect a font problem.
Comment 10 Alex Thurgood 2017-05-09 07:37:37 UTC
@Thanks Alan - I'm pretty certain the problem you are experiencing is already referenced here somewhere in the bugzilla, just a matter of finding it.
Comment 11 Alex Thurgood 2017-05-09 08:03:09 UTC
Confirming on

Version: 5.4.0.0.alpha0+
Build ID: 55833ef28adb67a34a61f545219f9ba9a7c1a4e5
CPU threads: 2; OS: Mac OS X 10.12.4; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 12 Alex Thurgood 2017-05-09 08:04:23 UTC
I am confirming only for LONGVARCHAR multiline field of the form. As one can see from the enclosed screenshot the date entries are correctly displayed in Apple Preview for all fields except the multiline control.
Comment 13 Alex Thurgood 2017-05-09 08:05:38 UTC
Created attachment 133181 [details]
Screenshot with master 5.4.0
Comment 14 Alex Thurgood 2017-05-09 08:12:09 UTC
Suspect duplicate of bug 92959
Comment 15 Alex Thurgood 2017-05-09 08:28:18 UTC
If this is the same bug as:

https://bz.apache.org/ooo/show_bug.cgi?id=114010

then the problem has been around since OOo3.3
Comment 16 QA Administrators 2018-05-10 02:32:07 UTC Comment hidden (obsolete)
Comment 17 Alan Wheeler 2018-05-14 14:24:44 UTC
No longer a problem in LibreOffice 6.0.3.2