Bug 107413 - FILEOPEN: RTF: Footer not imported
Summary: FILEOPEN: RTF: Footer not imported
Status: RESOLVED DUPLICATE of bug 143384
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: filter:rtf, preBibisect, regression
: 142903 (view as bug list)
Depends on:
Blocks: RTF-New-Import
  Show dependency treegraph
 
Reported: 2017-04-25 12:21 UTC by Xisco Faulí
Modified: 2022-02-01 22:55 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The example file in Word and Writer master (236.88 KB, image/png)
2022-01-30 22:44 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-04-25 12:21:59 UTC
Steps to reproduce:
1. Open attachment 63853 [details] from bug 49666

Observed behaviour: Footer isn't imported / displayed

Reproduced in 

Version: 5.4.0.0.alpha0+
Build ID: 7635e0c1c7f821a1081f8e3868f641ae74a172d6
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Jacques Guilleron 2017-04-25 13:09:16 UTC
Hello Xisco,

Reproduced too with:
LO  5.4.0.0.alpha0+
Build ID: 100e00fd3273536ebff130cfddc5da2b1fe609b1
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-20_05:12:24
Locale: en-US (fr_FR); Calc: CL
and
LO 3.6.1.2 (Build ID: e29a214)
Comment 2 Aron Budea 2017-10-25 18:36:39 UTC
Freezes LO 3.5.0.3. Footer is already missing with oldest commit of bibisect-43all. => notBibisectable
Comment 3 QA Administrators 2018-10-26 02:58:22 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2018-10-26 06:30:47 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: cec31fdedd7c94f4ebf903a66456a75867db22b0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-21_22:54:44
Locale: ru-RU (ru_RU); Calc: threaded
Comment 5 zcrhonek 2020-12-02 08:51:57 UTC
repro Version: 7.2.0.0.alpha0+
Build ID: 7673b027daed248d1be4dd1a773bfc0334a00c53
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded
Comment 6 m.a.riosv 2021-06-17 07:47:46 UTC
*** Bug 142903 has been marked as a duplicate of this bug. ***
Comment 7 David Nash 2021-06-17 07:53:39 UTC
Bug 142903 is about a footnote, imported but not numbered.
This bug, 107413, is about a footer.
Comment 8 Xisco Faulí 2021-11-08 16:10:24 UTC
*** Bug 142903 has been marked as a duplicate of this bug. ***
Comment 9 Gabor Kelemen (allotropia) 2022-01-30 22:44:42 UTC
Created attachment 177919 [details]
The example file in Word and Writer master

Looks good since:

https://git.libreoffice.org/core/+/c1ad429d925855c1baacbdeca1ef42f4486eb9c2

author	Attila Szűcs <szucs.attila3@nisz.hu>	Tue Jul 27 11:45:58 2021 +0200
committer	László Németh <nemeth@numbertext.org>	Wed Aug 25 13:45:23 2021 +0200

tdf#143384 DOCX import: fix SAXException at header with table

This is another example of negative page margin, which was worked around with a frame.
Comment 10 Gabor Kelemen (allotropia) 2022-01-30 22:45:30 UTC
Thanks Attila for fixing this one too!

*** This bug has been marked as a duplicate of bug 143384 ***
Comment 11 Xisco Faulí 2022-01-31 11:32:11 UTC
Unittest added in https://gerrit.libreoffice.org/c/core/+/129216
Comment 12 Commit Notification 2022-02-01 22:55:59 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5d3d1b8aa2b36986b7991c759133c3ddb8e2d516

tdf#107413: sw_rtfexport5: Add unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.