Bug Hunting Session
Bug 107435 - Non-exact paragraph line spacing has problems for CTL and CJK fonts
Summary: Non-exact paragraph line spacing has problems for CTL and CJK fonts
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: RTL-CTL Font-Rendering CJK Paragraph-Line-Spacing
  Show dependency treegraph
 
Reported: 2017-04-26 04:11 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-05-25 23:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (12.57 KB, application/wps-office.docx)
2017-04-26 04:11 UTC, Yousuf Philips (jay) (retired)
Details
Word PDF (673.88 KB, application/pdf)
2017-04-26 04:15 UTC, Yousuf Philips (jay) (retired)
Details
Word 2007 vs Writer 5.4 (191.23 KB, image/png)
2017-04-26 04:19 UTC, Yousuf Philips (jay) (retired)
Details
line spacing difference between 3.3, 4.0 and 6.0 (194.22 KB, image/png)
2017-10-04 19:25 UTC, Yousuf Philips (jay) (retired)
Details
how highlight looks on KacstBook (80.45 KB, image/png)
2017-10-07 08:36 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2017-04-26 04:11:25 UTC
Created attachment 132839 [details]
sample

Steps:
1) Open attached document
2) Export document as PDF and compare it with export from MS Word
3) If you dont have MS Word, find exported PDF in next comment
4) Notice how the paragraph line spacing in LO is alot smaller

Version: 5.4.0.0.alpha0+
Build ID: e4f28aea21ce7e8f960cc2062f83715549be215e
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86@71-TDF, Branch:master, Time: 2017-04-25_00:49:43
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Yousuf Philips (jay) (retired) 2017-04-26 04:15:24 UTC
Created attachment 132840 [details]
Word PDF
Comment 2 Yousuf Philips (jay) (retired) 2017-04-26 04:19:20 UTC
Created attachment 132841 [details]
Word 2007 vs Writer 5.4
Comment 3 Buovjaga 2017-04-30 11:45:27 UTC
Confirmed.

Arch Linux 64-bit
Version: 5.4.0.0.alpha1+
Build ID: aca48f46895811009ec90665d816ef835f0694be
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on 30th April 2017
Comment 4 Yousuf Philips (jay) (retired) 2017-10-02 20:16:43 UTC
raal, aron, xisco: can any of you guys bibisect this regression from 4.1?
Comment 5 Aron Budea 2017-10-03 04:30:06 UTC
Paragraph spacing seems the same in 3.3.0 to me, I don't think it's a regression.
Comment 6 Khaled Hosny 2017-10-04 11:46:16 UTC
I’d say Word line spacing is at fault here and LibreOffice is rendering the fonts as intended. I don’t believe in bug to bug compatibility with MS Office, and the line spacing changes is intended to fix bug like the ones described in bug 55469 which Word is still suffering from. You can’t have your cake and eat it.
Comment 7 Yousuf Philips (jay) (retired) 2017-10-04 19:25:39 UTC
Created attachment 136765 [details]
line spacing difference between 3.3, 4.0 and 6.0

(In reply to Aron Budea from comment #5)
> Paragraph spacing seems the same in 3.3.0 to me, I don't think it's a
> regression.

check the screenshot.
Comment 8 Yousuf Philips (jay) (retired) 2017-10-04 20:30:22 UTC
(In reply to Khaled Hosny from comment #6)
> I’d say Word line spacing is at fault here and LibreOffice is rendering the
> fonts as intended.

Any way to double check this with another app that you know always renders it correctly?
Comment 9 Khaled Hosny 2017-10-05 00:23:01 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> (In reply to Khaled Hosny from comment #6)
> > I’d say Word line spacing is at fault here and LibreOffice is rendering the
> > fonts as intended.
> 
> Any way to double check this with another app that you know always renders
> it correctly?

Firefox (at least on Linux) should be good.
Comment 10 Yousuf Philips (jay) (retired) 2017-10-07 08:36:19 UTC
Created attachment 136823 [details]
how highlight looks on KacstBook

(In reply to Khaled Hosny from comment #9)
> Firefox (at least on Linux) should be good.

I compared it and firefox had even a smaller line height and i think its because 1.15 line height in a word processor is calculated differently than a 1.15 in any brower.

I'll leave it up to you to close this bug if you feel the line height is correct, but i did notice that highlighting KacstBook text didnt reach the bottom of yaa or jeem, and at zoom over 180%, letters that go far enough under the line will get cropped like meem, jeem, and yaa.

If you say this is how it should be, then please close this bug.