Download it now!
Bug 107439 - librelogo does not work with language set to Finnish
Summary: librelogo does not work with language set to Finnish
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: LibreLogo
  Show dependency treegraph
 
Reported: 2017-04-26 08:14 UTC by Ari Latvala
Modified: 2019-10-09 08:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ari Latvala 2017-04-26 08:14:30 UTC
Took some time to realize that errors about LibreLogo syntax were shown because language was set to Finnish. After changing language to English (USA) commands started to work as expected
Comment 1 Jacques Guilleron 2017-04-27 16:00:01 UTC
HI Ari,

This code written in english:

TO tile
LEFT 60
REPEAT 2 [
    FORWARD 40 RIGHT 120 FORWARD 40 RIGHT 60
] FILL RIGHT 60
END

TO cube
colors = [“GOLD”, “TEAL”, “TOMATO”]
REPEAT 3 [ 
    PENCOLOR colors[REPCOUNT-1]
    FILLCOLOR colors[REPCOUNT-1]
    tile
    RIGHT 120
]
END

PICTURE “Reutersvärd triangle.svg” [
HIDETURTLE PENSIZE 0.1 RIGHT 30
REPEAT 3 [
    REPEAT 3 [
        PENUP FORWARD 60 PENDOWN
        d = HEADING
        HEADING 30
        cube
        HEADING d
    ]
    RIGHT 120
]
]

pasted into a Writer document,
can be translated to locale laanguage (French for me) by using magic wand icon 
from Logo toolbar.
I tried in Finnish. This works too.
Comment 2 Buovjaga 2017-04-27 17:01:14 UTC
Yep, pasted Jacques's code to Writer, clicked magic wand and play and it drew a Penrose triangle made up of cubes.

Ari: please give more information on how we can reproduce the error.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.2.2
Build ID: 5.3.2-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 3 Telesto 2017-04-30 12:41:05 UTC
I can reproduce it with
Version: 5.3.3.1
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
Threads CPU : 4; Version de l'OS :Windows 6.2; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-BE (nl_NL); Calc: CL

Steps to reproduce
1. User interface: Finnish 
2. Locale settings: Finnish
3. Logo command: repeat 400 [ circle 10 + repcount/10 fd 5 + repcount/10 lt 10 ]
Comment 4 Buovjaga 2017-04-30 14:24:13 UTC
Let's set to NEW, then.

Still no problem for me, though.

Versio: 5.3.2.2
Käännöksen ID: 5.3.2-3
CPU-säikeet: 8; Käyttöjärjestelmäversio: Linux 4.10; Piirtokomponentti: oletus; VCL: kde4; Tekstitaitto: uusi; 
Maa-asetus: fi-FI (fi_FI.UTF-8); Calc: group
Comment 5 QA Administrators 2018-05-01 02:32:02 UTC Comment hidden (obsolete)
Comment 6 Ari Latvala 2018-06-11 10:10:38 UTC
Hi, yes, this method seems to work but my point was the question, why this step is required, i.e. why LO does not recognize Logo language automatically regardless of the language settings? If this is intentional, then of course this bug can be closed as resolved.
Comment 7 László Németh 2018-10-08 13:12:41 UTC
Really, it would be fine to recognize this problem (trying to start a LibreLogo program with English commands in a document with different locale), and giving a choice to the user: (1) translate the program to the language of the document, and start the program,  or (2) change the language of the document, and start the program.
Comment 8 QA Administrators 2019-10-09 02:29:14 UTC Comment hidden (obsolete)
Comment 9 Ari Latvala 2019-10-09 08:58:54 UTC
Looks like this problem still exist

Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded