Download it now!
Bug 107511 - Performance regression in hunspell
Summary: Performance regression in hunspell
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
5.2.2.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, perf, regression
: 108393 108550 112467 (view as bug list)
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2017-04-28 18:46 UTC by Telesto
Modified: 2018-01-28 15:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (9.44 KB, application/vnd.oasis.opendocument.text)
2017-04-28 18:46 UTC, Telesto
Details
Process Monitor Output (16.82 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-17 18:49 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-04-28 18:46:13 UTC
Description:
I'm again (see bug 105426) noticing a small (1-2 sec) performance drop in hunspell with LibO5.4.0.0 (master) compared to 5.3.3.1 using a dutch dictionary


Steps to Reproduce:
1.Open attached file
2.Right click "Spoorwegmuseumpubliek"

Actual Results:  
Opens in 5-7 seconds

Expected Results:
LibO5.3.3.1 needs around 4 sec
LibO4.4.6.3 needs around 3-4 sec


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: 597a2f5d5bd37443262b0775b8439bc3502aef1b
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-04-26_22:29:37
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.3.3.1 
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-04-28 18:46:48 UTC
Created attachment 132945 [details]
Example file
Comment 2 Telesto 2017-05-03 16:05:48 UTC
The issue seems quite language dependent:

"wederrechtelijkez" (dutch)
Instant in versie: 4.4.6.3 
Acceptable but still a noticeable delay in Versie: 5.3.3.1 
Really slow in (3 sec): Version: 5.4.0.0.alpha1+

"Entscheidungstheoretischc" (german)
Instant in versie: 4.4.6.3
1 sec delay in 5.3.3.1 and 5.4.0.0.alpha1+

"Superciliousnessxd"
Instant in three versions
Comment 3 Buovjaga 2017-05-03 18:38:49 UTC
Cor: we need Dutch emergency help!
Comment 4 Aron Budea 2017-05-07 01:27:31 UTC
I can confirm the regression based on the description (I only checked using the word, not with the document), with symbol-enabled 5.4 master build (942f50e7d379ba5137f4a64d39bd06d6decad9e8) vs. 5.3.2.2.
Comment 5 Jacques Guilleron 2017-06-07 13:35:28 UTC
*** Bug 108393 has been marked as a duplicate of this bug. ***
Comment 6 Caolán McNamara 2017-06-15 14:58:45 UTC
Both 5.3 and 5.4 use the same version of hunspell so a difference between those version suggests the issue isn't hunspell itself
Comment 7 Telesto 2017-06-17 18:49:30 UTC
Created attachment 134085 [details]
Process Monitor Output

Not sure if it's helpful, but LibO5400b2 keeps accessing \share\config\soffice.cfg\ directory every-time I click for the spelling suggestion. LibO5331 does this only the first time.
Comment 8 kontaktak 2017-06-19 06:36:22 UTC
(re: comment 5 - bug 108393)

Allow me to add that I noticed the following with spellingcheck

5.1.4 too slow / not possible to use
5.1.5 works fine
5.1.6.2 works fine
everything above 5.1.6.2 too slow / not possible to use
Comment 9 Telesto 2017-06-19 10:33:36 UTC
kontaktak thanks for testing! LibO 5.1.6.2 should be the reference point.
'wederrechtelijkez' opens immediately with 5.1.6.2 and takes 3 seconds with  5.4.0.0.beta2
Comment 10 Telesto 2017-06-22 15:01:36 UTC
*** Bug 108550 has been marked as a duplicate of this bug. ***
Comment 11 Telesto 2017-06-28 18:32:21 UTC
Hmm, working perfectly fine in (no repro)
Version: 6.0.0.0.alpha0+
Build ID: 9f3814af7264ce90685a82cbf4eb015a38f22bf7
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-28_00:47:42
Locale: nl-NL (nl_NL); Calc: CL

but it's  still broken in: 
Versie: 5.4.0.1 
Build ID: 962a9c4e2f56d1dbdd354b1becda28edd471f4f2
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 12 kontaktak 2017-07-26 17:40:26 UTC
Looks like Version 5.4.0.3 has *less* problems with dutch dictionary.

During checking a 2 page document "system not reacting" message was visible only 1x 


"Spoorwegmuseumpubliek" takes 5.1 sec (in 5.1.6.2 - <3sec)
"wederrechtelijkez"  takes 3.1 sec (in 5.1.6.2 - <1sec)
Comment 13 Emil Tanev 2017-10-30 15:55:30 UTC
*** Bug 112467 has been marked as a duplicate of this bug. ***
Comment 14 Telesto 2017-12-19 21:13:45 UTC
I'm not noticing any lag with:
Version: 6.1.0.0.alpha0+
Build ID: aad9c6da5154a89c6ef02214d1122d4b444eea23
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-15_22:56:44
Locale: nl-NL (nl_NL); Calc: CL
Comment 15 Telesto 2018-01-28 15:07:11 UTC
No repro with
Version: 6.1.0.0.alpha0+
Build ID: ea89dabf8b6363972190a6b50c527c418d51c2c7
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-01-27_22:55:15
Locale: nl-NL (nl_NL); Calc: CL