Download it now!
Bug 107616 - UI: No indication which cell is the parent of a border between adjacent cells in Formatting Cells dialog
Summary: UI: No indication which cell is the parent of a border between adjacent cells...
Status: RESOLVED DUPLICATE of bug 87787
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.6.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-04 08:20 UTC by Kevin
Modified: 2017-05-08 05:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2017-05-04 08:20:03 UTC
Description:
The UI forces the user to guess which cell contains the border to be edited.

Steps to Reproduce:
1. add a border to the right edge of cell A1
2. select cell B1 and choose "Format Cells ..."
3. go to the borders tab (the border, now the left edge of B1, is not available to be edited)
4. repeat steps 1-3 in Excel - a border can be edited from any cell that it borders.

Actual Results:  
calc is unintuitive and forces the user into trial and error to remove or edit an existing border

Expected Results:
calc should behave like Excel, without the Excel bugs, and without Excel's horrible UI problems. In no case should Calc be buggier or harder to use than Excel!


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.81 Safari/537.36
Comment 1 Kevin 2017-05-04 08:24:17 UTC
Note: It could be argued that there's some value to having a double border between A1 and B1. I don't agree - I would rather have it work like Excel - but in any case, even if this is "a feature not a bug", the feature doesn't work:

1. Create a black border on the right side of A1
2. Create a red border on the left side of B1

result: they occupy the same pixels and the user sees only the black
Comment 2 Kevin 2017-05-04 08:29:38 UTC
This issue is but the tip of the iceberg. The whole UI for borders and backgrounds is badly in need of attention. If you try to create an intricate table that uses backgrounds and borders to make the data more accessible you'll see. I'm doing a huge chart with the chord changes to every Beatles song. I'm not using any of the spreadsheet features - just working long hours on formatting. Excel and Calc are painfully, horrendously buggy and unintuitive, but in very different ways. It's incredibly frustrating. Calc should be a smart, non-corporate person's dream come true after the nightmare of Excel. Instead, it's just a different nightmare.
Comment 3 Buovjaga 2017-05-07 11:54:33 UTC
Kevin: I found bug 87787. Would you be content, if I closed your report as duplicate?
Comment 4 Kevin 2017-05-07 21:35:36 UTC
(In reply to Buovjaga from comment #3)
> Kevin: I found bug 87787. Would you be content, if I closed your report as
> duplicate?

I wasn't happy with 87787 - it seems to imply that the problem has been resolved. It hasn't. I added a comment there so I guess we can get red of this 107616. Is there some intelligent design behind this idea of having separate borders for adjacent cell boundaries that I'm missing?
Comment 5 Buovjaga 2017-05-08 05:37:31 UTC
(In reply to Kevin from comment #4)
> (In reply to Buovjaga from comment #3)
> > Kevin: I found bug 87787. Would you be content, if I closed your report as
> > duplicate?
> 
> I wasn't happy with 87787 - it seems to imply that the problem has been
> resolved. It hasn't. I added a comment there so I guess we can get red of
> this 107616. Is there some intelligent design behind this idea of having
> separate borders for adjacent cell boundaries that I'm missing?

If it implied the problem is resolved, it would be closed. The report was filed by a person in the design team and the team agrees things need to change.
Thanks, closing as dupe.

*** This bug has been marked as a duplicate of bug 87787 ***