Bug 107679 - UX: Removing a table border in the Table Properties menu needs three instead of the expect two clicks
Summary: UX: Removing a table border in the Table Properties menu needs three instead ...
Status: RESOLVED DUPLICATE of bug 139018
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 108276 (view as bug list)
Depends on:
Blocks: Writer-UX Writer-Table-Properties-Dialog
  Show dependency treegraph
 
Reported: 2017-05-07 12:46 UTC by Telesto
Modified: 2021-05-23 07:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.96 KB, application/vnd.oasis.opendocument.text)
2017-05-09 13:07 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-07 12:46:24 UTC
Description:
Removing a table border in the Table Properties menu (user defined) needs three clicks. But I'm not seeing any purpose for the second click? Just toggling on/off seems to be enough (to me).

Steps to Reproduce:
1. Open attached file 
2. Select the top row (blue border)
3. Right click -> Table Properties
4. Go to tab borders
5. A single click on (blue) line in the line arrangement preview (select)
6. A second single click on the same line again -> 'blue line changes to grey'
7. A third single click in the gray line -> line disappears

Actual Results:  
Three clicks for removing a table border in the line arrangement preview

Expected Results:
Two clicks for removing a border line


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha1+
Build ID: 274ecb49b70b3f01d47546e3b44317946c106042
CPU threads: 4; OS: Windows 6.2; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-05_22:45:07
Locale: nl-BE (nl_NL); Calc: single


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2017-05-07 16:56:07 UTC
http://documentation.libreoffice.org/assets/Uploads/Documentation/en/WG4.2/PDF/WG4209-WorkingWithTables.pdf
Page 13:
"When the selected cells have different styles of border the User-defined area shows the border as a gray line. You can click on the gray line to choose a new border style (first click), leave the border as it is (second click) or delete the border (third click)."

Could it be made somehow more obvious? Personally, this is news to me. Let's circle this through the UX meatgrinder.
Comment 2 Telesto 2017-05-08 09:47:59 UTC
Mean reason for my confusion is that I expected that the second click meant, back to default border. I was certain that the second click removed the blue border because it didn't show up anymore.
Comment 3 Heiko Tietze 2017-05-09 12:45:03 UTC
I would keep the less known property of the grey line for inherited properties first to show this to users. Otherwise you always click once and never see the undetermined state. -> WFM - but lets see if others disagree

PS: As there is no attachment simply create a table and set the border color of some cells.
Comment 4 Telesto 2017-05-09 13:07:27 UTC
Created attachment 133193 [details]
Example file
Comment 5 Buovjaga 2017-06-04 18:36:16 UTC
*** Bug 108276 has been marked as a duplicate of this bug. ***
Comment 6 Heiko Tietze 2020-07-27 14:38:28 UTC
(In reply to Heiko Tietze from comment #3)
> WFM - but lets see if others disagree

No further opinion, let's keep it.
Comment 7 Telesto 2021-05-23 07:41:25 UTC

*** This bug has been marked as a duplicate of bug 139018 ***