Bug 107694 - Impress: "Shrink text on overflow" text box option not recognized from PPTX, text overlapping
Summary: Impress: "Shrink text on overflow" text box option not recognized from PPTX, ...
Status: RESOLVED DUPLICATE of bug 122023
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PPTX-Paragraph
  Show dependency treegraph
 
Reported: 2017-05-08 06:15 UTC by pooja.dhannawat535
Modified: 2020-11-02 12:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample pptx with overlapping text (2.08 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-05-08 06:15 UTC, pooja.dhannawat535
Details
How it looks in my system (175.86 KB, image/jpeg)
2017-05-08 06:16 UTC, pooja.dhannawat535
Details
Lines are rendered overlapping (23.99 KB, application/zip)
2017-08-08 04:57 UTC, Mike
Details
PPTX, as it is rendered in Powerpoint 2007 (94.99 KB, image/png)
2017-08-08 04:58 UTC, Mike
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pooja.dhannawat535 2017-05-08 06:15:51 UTC
Created attachment 133148 [details]
Sample pptx with overlapping text

I am using libreoffice 5.3.2 version on linux 14.04 (32bit system). When I try to load any pptx file sometimes the text is overlapping. And if I keep the file open for few seconds then the overlapping of text issue is resolved. I have OpenGL disabled. Kindly help me in understanding the cause of this issue and how to fix this.

As the presentation is confidential attaching one slide with random text so that issue can be identified. All required fonts are installed on my system. I am using libreoffice for pptx to pdf conversion.

Please find attached sample pptx and screen-shot of how it looks in my system.
Comment 1 pooja.dhannawat535 2017-05-08 06:16:29 UTC
Created attachment 133149 [details]
How it looks in my system
Comment 2 Xisco Faulí 2017-05-09 14:46:54 UTC
COnfirmed in

- Version: 5.4.0.0.alpha1+
Build ID: f12096272e684ddcd8ffa4e34dcb0a680cc594c2
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group


- Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

- Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

- Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

it became to be overlapped after 798a563db133ebed3876c245459d90ef54ee7c9a. Hoewever, it wasn't correct before neither.
Comment 3 pooja.dhannawat535 2017-05-10 11:07:42 UTC
Once you will click on the text in this slide the text overlapping issue will go.

Kindly help me to understand how should I fix this as I am using LibreOffice programatically using api's
Comment 4 pooja.dhannawat535 2017-05-10 11:08:39 UTC Comment hidden (no-value)
Comment 5 pooja.dhannawat535 2017-05-16 05:37:47 UTC Comment hidden (no-value)
Comment 6 Mike 2017-08-08 04:57:21 UTC Comment hidden (no-value)
Comment 7 Mike 2017-08-08 04:58:26 UTC Comment hidden (no-value)
Comment 8 QA Administrators 2018-08-09 02:35:30 UTC Comment hidden (obsolete)
Comment 9 Timur 2018-08-09 14:12:06 UTC
Repro in 6.2+ for attachment 133148 [details]. 
Looks like LO doesn't recognize "Shrink text on overflow" option used in text box.
Other options preview fine: "Do not autofit" and "Resize shape to fit text". 

Mike's issue was different and it's resolved now, tested 5.4.7. Removing posts.
Comment 10 Timur 2020-11-02 12:50:07 UTC
I don't know why I didn't mark other as a duplicate of this one, but now they have duplicate, so easier to mark this one.

*** This bug has been marked as a duplicate of bug 122023 ***