Bug 107710 - MAILMERGE: Crash when sending mail with wrong password
Summary: MAILMERGE: Crash when sending mail with wrong password
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2017-05-08 21:17 UTC by Gabor Kelemen
Modified: 2019-04-26 06:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2017-05-08 21:17:11 UTC
1, Set up your Mail Merge access on the Mail Merge settings page, but type a wrong password
2, Try to send a mail merge e-mail
3, Upon pressing the Send Mail button current LO 5.4 alpha (but 5.3.2 as well on Ubuntu) crashes with the following debug messages on the console:

$ warn:ucb.ucp.gio:5062:1:ucb/source/ucp/gio/gio_content.cxx:396: ignoring GError "Operation not supported" for <>
warn:vcl.layout:5062:1:vcl/source/window/builder.cxx:520: No default button defined in modules/swriter/ui/mmcreatingdialog.ui
warn:sw:5062:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:5062:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:5062:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:5062:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:5062:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:sw:5062:1:sw/inc/swrect.hxx:283: SVRect() without Width or Height
warn:vcl.layout:5062:1:vcl/source/window/builder.cxx:520: No default button defined in modules/swriter/ui/mmsendmails.ui
warn:sfx.view:5062:1:sfx2/source/view/viewfrm.cxx:2947: SID_SIDEBAR state requested, but no task pane child window exists for this ID!
Python exception: <class 'smtplib.SMTPAuthenticationError'>: (535, b'5.7.8 Username and Password not accepted. Learn more at\n5.7.8  https://support.google.com/mail/?p=BadCredentials i199sm11260750wmf.33 - gsmtp'), traceback follows
  File "/home/gabor/src/core/instdir/program/mailmerge.py", line 132, in connect
    self.server.login(user, password)
  File "/home/gabor/src/core/instdir/program/python-core-3.5.0/lib/smtplib.py", line 729, in login
    raise last_exception
  File "/home/gabor/src/core/instdir/program/python-core-3.5.0/lib/smtplib.py", line 720, in login
    initial_response_ok=initial_response_ok)
  File "/home/gabor/src/core/instdir/program/python-core-3.5.0/lib/smtplib.py", line 641, in auth
    raise SMTPAuthenticationError(code, resp)


warn:legacy.osl:5062:1:sw/source/uibase/dbui/mailmergehelper.cxx:157: exception caught
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
warn:sfx.doc:5062:1:sfx2/source/doc/docfile.cxx:682: Physical name not convertible!
Python exception: <class 'smtplib.SMTPSenderRefused'>: (530, b'5.5.1 Authentication Required. Learn more at\n5.5.1  https://support.google.com/mail/?p=WantAuthError i199sm11260750wmf.33 - gsmtp', 'kelemeng@ubuntu.com'), traceback follows
  File "/home/gabor/src/core/instdir/program/mailmerge.py", line 285, in sendMailMessage
    self.server.sendmail(sendermail, truerecipients, msg.as_string())
  File "/home/gabor/src/core/instdir/program/python-core-3.5.0/lib/smtplib.py", line 862, in sendmail
    raise SMTPSenderRefused(code, resp, from_addr)


Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
Throwing InvalidHeaderException
warn:sfx.doc:5062:1:sfx2/source/doc/docfile.cxx:682: Physical name not convertible!
Comment 1 Xisco Faulí 2017-10-30 10:39:01 UTC
Hi Gabor,

I can't reproduce it in

Version: 6.0.0.0.alpha1+
Build ID: fc4f2f1b0f8c286e9ae259c44fb249261a8ac47f
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Does it crash when you click on 'Send E-mail messages' button ?
Comment 2 QA Administrators 2018-05-02 15:47:32 UTC Comment hidden (obsolete)
Comment 3 Gabor Kelemen 2018-05-03 08:34:12 UTC
I can't reproduce this anymore.
Comment 4 johnkimber 2019-04-26 05:04:05 UTC
 It is because Google blocks gmail smtp sign-in attempts from apps which do not use modern security standards (mentioned on their support page). You can however, turn on/off this safety feature by going to the link below:

Go to this link and select Turn On
https://www.google.com/settings/security/lesssecureapps

Moreover google block an ip when you try to send a email since a unusual location, so, you can unblock in the next link
https://support.google.com/accounts/answer/6009563

and clicked in

accounts.google.com/DisplayUnlockCaptcha .


http://net-informations.com/python/net/email.htm