Download it now!
Bug 107721 - MAILMERGE: Crash while printing new document
Summary: MAILMERGE: Crash while printing new document
Status: RESOLVED DUPLICATE of bug 107729
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2017-05-09 11:09 UTC by Xisco Faulí
Modified: 2017-05-31 08:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SwMMResultPrintDialog::PrintHdl_Impl(Button%20*)"]


Attachments
backtrace (28.22 KB, text/plain)
2017-05-09 11:25 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-05-09 11:09:11 UTC
Steps to reproduce:
1. Open new writer document
2. Go to Tools - Mail Merge Wizards
3. Select 'Create new document' on the first dialog and click Next -> A new document is created in background
4. Close the mailmerge wizard by clicking Cancel and the 
5. Close the document called 'Untitled 2'
6. Go to 'Untitled 1' document and click on 'Print Merged Documents'
7. Click on 'Print Documents'

CRASH.

Just for the record, I don't have any printer installed.

Reproduced in

Versión: 5.3.2.2
Id. de compilación: 6cd4f1ef626f15116896b1d8e1398b56da0d0ee1
Subproc. CPU: 1; SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group
Comment 1 Xisco Faulí 2017-05-09 11:25:16 UTC
Created attachment 133187 [details]
backtrace
Comment 2 Xisco Faulí 2017-05-10 10:18:06 UTC
The crash was introduced when the mailmerge dialog was refactored in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=59a3d972d2909650506409eeb6d4a71fa263dc29..b86b97e54590872fc0ea85fbea22c2d00d241181

Adding Kendy as Cc since he did the refactoring.
Comment 3 Xisco Faulí 2017-05-31 08:14:05 UTC

*** This bug has been marked as a duplicate of bug 107729 ***