Download it now!
Bug 107744 - Disable anti-aliasing for fonts does not work
Summary: Disable anti-aliasing for fonts does not work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisectRequest, regression
: 107760 (view as bug list)
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2017-05-10 06:50 UTC by Tyco72
Modified: 2020-03-25 13:33 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Anti-aliasing still present (10.40 KB, image/png)
2020-03-23 23:04 UTC, 7qia0tp02
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tyco72 2017-05-10 06:50:19 UTC
Description:
LO version: LO 5.3.2.2 x64
OS: Windows 7 SP1 x64

Disable anti-aliasing for fonts does not work

Steps to Reproduce:
1. Open menu 'Tools' → Options → LibreOffice → View
2. Deselect the option "Use anti-aliasing"
3. Restart LibreOffice


Actual Results:  
Bug: The anti-aliasing is not disabled. Even if I disable the OpenGL and /or HW acceleration, nothing changes.
In Windows all the anti aliasing are disabled and all other applications are shown without anti-aliasing, as well LibreOffice 5.2.5.1. 

Expected Results:
Anti-aliasing should be disabled. Blurred fonts are very uncomfortable for my sight. I have to switch back to LO 5.2.5.1. Please someone fix it soon.


Reproducible: Always

User Profile Reset: No

Additional Info:
I set it as major bug, because blurred fonts for some people are so uncomfortable, that they can't work with it.


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 tommy27 2017-05-10 09:50:40 UTC
would you please post a screenshot?

did you try LibO 5.2.7.2? is it unaffected by that bug?
Comment 2 V Stuart Foote 2017-05-10 21:29:36 UTC
*** Bug 107760 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2017-05-10 21:37:53 UTC
Confirm the apparent non-function of the "Use anti-alaising" checkbox.

Believe this is all wrapped up in Windows font rendering issues of bug 106990

Font rendering has all shifted to DirectWrite, and OpenGL rendering matches Default GPU/CPU rendering, but quality of the font rendering is rough--so UI does not seem to respond to the "Use anti-alaising"

M. Meeks thinks a change to CLEARTYPE_QUALITY rather than DEFAULT_QUALITY may help with the font rendering to UI and to document canvas--if not a more complete rework of the DirectWrite rendering on Windows builds becomes more important (bug 107521)

=-ref-= 

https://bugs.documentfoundation.org/show_bug.cgi?id=106990#c60
Comment 4 Luis 2017-08-21 11:30:28 UTC
I confirm this issue.

Disable ClearType don't change screen appearance.

I want to do some test without anti-aliasing enabled but I can't.

Version: 5.4.1.0.0+ (x64)
Build ID: b78c398817940bbbe0b9ebe848a923cef1856758
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-4, Time: 2017-07-28_09:02:44
Locale: es-ES (es_ES); Calc: group
Comment 5 Mercury 2017-09-02 18:47:57 UTC
Confirmed.

This way does not work:
https://ask.libreoffice.org/en/question/92250/how-to-disable-libreoffice-5322-font-rendering/

I’ll check 5.4.1.2 (installer needs reboot).
Comment 6 Mercury 2017-09-02 18:55:27 UTC
5.4.1.2 still anti-aliasing forced, but rendering is horrible (eats the rightmost column of pixels). Reverting to an old version.
Comment 7 Mercury 2017-09-02 19:25:28 UTC
I discovered that fonts were broken in 5.3.
Comment 8 pureocean1 2017-09-04 03:53:10 UTC
I installed v5.4.1. Even if disabled anti-aliasing and H/W accel., fonts still rasterizes by DirectWrite/ClearType.

However, I disabled ClearType/DirectWrite on Registry for standart GDI font rendering: [HKEY_CURRENT_USER\Control Panel\Desktop]
; Value "0" or "1": switch to gray font smoothing (Smooth edges of screen fonts: 'Standard')
; Value "2": switch to colored font smoothing (Smooth edges of screen fonts: 'ClearType')
"FontSmoothingType"=dword:00000001

Or, run this BATch file as Admin for disable Cleartype and enable GDI font rendering: https://paste.ee/r/1h0lh

(Need log-off and again log-in on Windows).

*

I tried 5.2.7.2. GDI font rendering works (of course if disabled anti-aliasing and H/W accel. from Settings and Tools -> Options -> Advanced -> Open Expert Configuration: org.openoffice.Office.Common -> View -> FontAntiAliasing: false).
Comment 9 Tyco72 2017-10-05 08:41:20 UTC
Thank you. In both paths:
[HKEY_CURRENT_USER\Control Panel\Desktop]
[HKEY_USERS\.DEFAULT\Control Panel\Desktop]

I have:
"FontSmoothing=0"
"FontSmoothingtype=1"

(I don't want clear type also in Windows)

In LO: Tools -> Options -> Advanced -> Open Expert Configuration: org.openoffice.Office.Common -> View -> FontAntiAliasing = false

But it doesn't work. (WIn7 SP1 64 bit). Will the latest LO version help?

Where can I disable the and H/W accel.?
Comment 10 Tyco72 2018-03-28 06:56:44 UTC
I have tested now the LibreOffice 6.0.2.1 and the disabling of the font rendering works! The bug can be closed.
Comment 11 7qia0tp02 2020-03-23 23:04:21 UTC
Created attachment 158912 [details]
Anti-aliasing still present
Comment 12 7qia0tp02 2020-03-23 23:04:56 UTC
(In reply to 7qia0tp02 from comment #11)
> Created attachment 158912 [details]
> Anti-aliasing still present

Still a problem in 
Version: 6.4.1.2 (x64)
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

"Use anti-aliasing" is disabled in Options -> View, but text in Writer is still anti-aliased.
Comment 13 Michael Meeks 2020-03-24 10:22:11 UTC
Hi Lubos - might be interesting for Skia =) use-anti-aliasing seems to mean "enable cleartype" in the modern world - and some people want to be able to turn that off; FYI =)
Comment 14 Tyco72 2020-03-24 17:54:50 UTC
Thank you for your feedback, then I open the bug again.
I had set it as "Worksforme" because I have actually disabled the anti aliasing in the Windows registry, and it affects the windows for all applications.
I hope it will be properly solved in LO.
Comment 15 Commit Notification 2020-03-25 13:32:55 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/208bb103d3ad93c2356c60174a49204a3e919f74

no reason for the FontAntiAliasing setting being UNX-only (tdf#107744)

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.