Download it now!
Bug 107814 - fresh install with default settings in clean Windows 10 assigns rtf file type to open with Calc instead of Writer
Summary: fresh install with default settings in clean Windows 10 assigns rtf file type...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: All Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2017-05-13 05:44 UTC by Robert
Modified: 2018-07-19 02:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2017-05-13 05:44:58 UTC
This has been present in several recent incarnations of LibreOffice:
On a new, clean installation of Windows 10, installing LibreOffice without changing any of the default options, results in files of type .rtf to open with LibreOffice Calc.
They should either be left alone, or else open with Writer.
If one customizes the LibreOffice installation to also associate Word files with LibreOffice, then it is fixed, but with the default settings it associates only spreadsheet files with LibreOffice, but erroneously including rtf.
Comment 1 tommy27 2017-05-13 07:36:02 UTC
hi, you reported this issue with LibO 5.2.1.2
is this issue still present with latest LibO 5.3.3.2?
Comment 2 Robert 2017-05-13 10:58:30 UTC
Hi Tommy,
Yes, I tried with another fresh install of Windows 10 Home and a new download of LibO 5.3.3, and the behavior is still the same: before the LibO installer is run, rtf is associated with WordPad, after the install it is on Calc.
Comment 3 Buovjaga 2017-05-14 11:51:21 UTC
(In reply to Robert from comment #0)
> with the default settings it
> associates only spreadsheet files with LibreOffice

That's a weird default setting and I have never seen it. Usually it associates with all of them.

I can reproduce it, if I install and unselect all the other associations.

However, Calc can open RTF files: bug 59016 explains it. Maybe this association is not wise, though. Let's set to NEW.

Version: 5.3.3.2 (x64)
Build ID: 3d9a8b4b4e538a85e0782bd6c2d430bafe583448
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: fi-FI (fi_FI); Calc: group
Comment 4 Robert 2017-05-14 12:00:16 UTC
It would certainly make more sense to associate RTF with LibO Writer rather than Calc, or else leave it with Wordpad.

The reason I got going on this issue is that a friend who is not computer-savvy at all, had translated a long poem in an rtf document, then he switched to a new computer with Libreoffice and there it opened with Calc -- since he didn't realize that he was using a spreadsheet application, he continued in Calc which on the first save prompted him to save in ods format, so now his poem is in a spreadsheet which is not very convenient, and I had to show him how to transform it back into an rtf and fix the file association so it opens with Writer.
Comment 5 QA Administrators 2018-07-19 02:41:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug