Bug 107851 - Make style-focused formatting toolbar context-sensitive
Summary: Make style-focused formatting toolbar context-sensitive
Status: RESOLVED DUPLICATE of bug 106846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Toolbar-Formatting-Styles Style-Formatting-Writer-Toolbar
  Show dependency treegraph
 
Reported: 2017-05-14 20:45 UTC by Thomas Lendo
Modified: 2018-04-15 19:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-05-14 20:45:20 UTC
The style-focused formatting toolbar of bug 106781 should be context-sensitive like the standard formatting toolbar and in the same way.

Actual result:

Toolbar "Formatting (Styles)" is now inserted in addition to the "Formatting" toolbar on the 3rd position. That's because it isn't content-sensitive and to avoid jumps of the view canvas when clicking on an image, etc.

Expected result, when "Formatting (Styles)" toolbar instead of "Formatting" toolbar is activated:

- Writing text, the "Formatting (Styles)" toolbar is shown.
- Clicking on a frame, the "Formatting (Styles)" toolbar is replaced by the Frame toolbar.
- Clicking on a picture, the "Formatting (Styles)" toolbar is replaced by the Frame and Image toolbars.


Version: 5.4.0.0.alpha1+
Build ID: b82c9439287f58a02a2b42d737fcf110fbfb1244
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-14_01:01:26
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 1 Yousuf Philips (jay) (retired) 2017-05-15 11:50:31 UTC

*** This bug has been marked as a duplicate of bug 106846 ***