Bug Hunting Session
Bug 107859 - Incoherent screen refreshing, freezes !
Summary: Incoherent screen refreshing, freezes !
Status: RESOLVED DUPLICATE of bug 105863
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-15 08:42 UTC by DoMi.....
Modified: 2017-05-18 00:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DoMi..... 2017-05-15 08:42:02 UTC
Description:
Since the 5.3.2.2 release, the screen is flashing and sometimes the application freeze definitivly. (Windows 7 pro with NVidia Quadro 2000M)
The font used for the menu is a bold one !
No more problems when I'm coming back on release 5.3.1.2 !

I have notice that some fonts are no more include on version 5.3.3.2, why ?
Carlito-Bold.ttf
Carlito-BoldItalic.ttf
Carlito-Italic.ttf
Carlito-Regular.ttf
DejaVuMathTeXGyre.ttf
DejaVuSans-Bold.ttf
DejaVuSans-BoldOblique.ttf
DejaVuSans-ExtraLight.ttf
DejaVuSans-Oblique.ttf
DejaVuSans.ttf
DejaVuSansCondensed-Bold.ttf
DejaVuSansCondensed-BoldOblique.ttf
DejaVuSansCondensed-Oblique.ttf
DejaVuSansCondensed.ttf
DejaVuSansMono-Bold.ttf
DejaVuSansMono-BoldOblique.ttf
DejaVuSansMono-Oblique.ttf
DejaVuSansMono.ttf
DejaVuSerif-Bold.ttf
DejaVuSerif-BoldItalic.ttf
DejaVuSerif-Italic.ttf
DejaVuSerif.ttf
DejaVuSerifCondensed-Bold.ttf
DejaVuSerifCondensed-BoldItalic.ttf
DejaVuSerifCondensed-Italic.ttf
DejaVuSerifCondensed.ttf
EmojiOneColor-SVGinOT.ttf

 Tks for your fantastic work.
   Dominique

Steps to Reproduce:
1. Immediately when the windows open


Actual Results:  
Libreoffice windows flashing and freeze.

Expected Results:
No latency, no flashing


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 V Stuart Foote 2017-05-15 14:22:17 UTC
Those fonts are bundled. If they were removed during install you now have a bad/incomplete installation.

First, check the .MSI install package size against the HASH value listed in the "details" MirrorBrain meta file for the build [1]. That will assure you the package is complete.

Then, do a complete uninstall of LibreOffice. And check that the LibreOffice provided fonts [2] are all gone (the LO uninstaller should remove them when the ref-count reduces to 0).

Reboot.

Perform a fresh installation of LibreOffice, I'd suggest you capture an installation log--so the install must be from a command window.

Use the command:

msiexec.exe /i LibreOffice_5.3.3.2_Win_x64.msi /L*v install5332log.txt

Check the result, look at the installed fonts and run LibreOffice. If still issues, please ZIP the install log and attach it to this bug.  If all is good please close as WORKSFORME or INVALID


=-ref-=
[1] http://downloadarchive.documentfoundation.org/libreoffice/old/

[2] http://opengrok.libreoffice.org/xref/core/external/more_fonts/Module_more_fonts.mk
Comment 2 DoMi..... 2017-05-17 23:14:48 UTC
  Hello,
 I have completely remove the 5.3.1.2 and install the 5.3.3.2 release. 
 Same problem : the menus of Libreoffice are flashing when the mice arrow is flying over, they whispered and reappear !
 When I came back to the 5.3.1.2 (x86) release, the menus refreshing is ok.

There is no problem with the fonts. The same are present with the 2 release. 
Sorry !

 Best regards.
   Dominique
Comment 3 V Stuart Foote 2017-05-18 00:31:28 UTC

*** This bug has been marked as a duplicate of bug 105863 ***