Bug Hunting Session
Bug 107869 - Doing a few undo-redo cycle of deletion of a row with comment crashes Calc
Summary: Doing a few undo-redo cycle of deletion of a row with comment crashes Calc
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected
Depends on:
Blocks:
 
Reported: 2017-05-15 14:42 UTC by Aron Budea
Modified: 2018-12-07 19:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["ScPostIt::UpdateCaptionPos(ScAddress const &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-05-15 14:42:51 UTC
- Add a comment to an empty cell in Calc.
- Delete the row with comment.
- Undo-redo deletion a few times.

=> Calc crashes.

Reproduced using 5.3.3.2 / Windows 7 and 5.2.2.2 / Ubuntu 16.04.
Crash report:
http://crashreport.libreoffice.org/stats/crash_details/b7bbd14f-86c5-452b-b147-d20ab6cc6c22

There is no crash in master branch, and it could be reverse-bibisected to the following commit using repo bibisect-linux-64-5.4.
Eike, could you please backport the fix to 5.3?

https://cgit.freedesktop.org/libreoffice/core/commit/?id=06e427c24d75311c0ab79d2da586b961881db766
author		Eike Rathke <erack@redhat.com>	2017-04-12 21:24:34 (GMT)
committer	Eike Rathke <erack@redhat.com>	2017-04-12 22:48:47 (GMT)

"control deletion of SdrCaptionObj within ScCaptionPtr by refcount"
Comment 1 Aron Budea 2017-05-15 14:43:51 UTC
Closing as fixed, since there's only a crash in 5.3.
Comment 2 Eike Rathke 2017-05-15 15:37:05 UTC
(In reply to Aron Budea from comment #0)
> There is no crash in master branch, and it could be reverse-bibisected to
> the following commit using repo bibisect-linux-64-5.4.
> Eike, could you please backport the fix to 5.3?
That is one commit of a series of ~42 or so related commits.. I'd rather not backport that bunch.
Comment 3 Aron Budea 2017-05-16 01:25:41 UTC
That's understandable, let me remove the tag.
Comment 4 Commit Notification 2018-12-07 19:44:57 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2f9ce888e1b2c1479a227b9833733098d8197159%5E%21

uitest for bug tdf#107869

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.