Download it now!
Bug 107871 - Libreoffice base does not follow system locale
Summary: Libreoffice base does not follow system locale
Status: RESOLVED DUPLICATE of bug 83535
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-15 14:54 UTC by Ednilson Miura
Modified: 2017-05-15 15:09 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the problem. (40.79 KB, image/png)
2017-05-15 14:54 UTC, Ednilson Miura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ednilson Miura 2017-05-15 14:54:07 UTC
Created attachment 133338 [details]
Screenshot showing the problem.

With a Suse SLED12-SP1 with libreoffice 5.1.2 installed, the last l10n package you install changes the window title for libreoffice base.

Setup:
- SLED12-SP1 (Same problem with Suse SLES12-SP1 or OpenSuse Leap42.2)
- Libreoffice-base installed
- Locale set to en_US (POSIX)

Steps:
- install some libreoffice l10n (in suse,  zypper install libreoffice-l10n-ar)
- Open libreoffice base
- Create a new database (just follow next-next wizard)
- Inside the new database, create a new table (just next-next wizard)
- Open the new table
- Check the window title

Expected result:
- Window title should stay in the system locale

Obtained result:
- Window title changes to last installed l10n package

Obs: 
- This behaviour only occours on libreoffice base. The original text on the title says "Table Data View".
- Openoffice maintainers from Suse asked to open a ticket here, because it does not appear to be related to Suse packaging.
Comment 1 Alex Thurgood 2017-05-15 15:09:38 UTC

*** This bug has been marked as a duplicate of bug 83535 ***