Bug 107912 - headless firstrun crashes (exit code 81)
Summary: headless firstrun crashes (exit code 81)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-05-17 15:00 UTC by duge
Modified: 2017-05-18 12:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
strace on LibreOffice-5.3.3.2 (1.15 MB, text/plain)
2017-05-17 15:00 UTC, duge
Details

Note You need to log in before you can comment on or make changes to this bug.
Description duge 2017-05-17 15:00:29 UTC
Created attachment 133375 [details]
strace on LibreOffice-5.3.3.2

OS: openSUSE 42.2 (x86_64)

Steps to reproduce:


1. delete ~/.config/libreoffice/ to get a firstrun


2. run one of the following commands (same result for all commands):

./soffice.bin --headless --nologo --nofirststartwizard '--accept=socket,host=127.0.0.1,port=8100;urp;StarOffice.service'

./soffice.bin --headless



actual result:
./soffice.bin quits immediately, returning exit code 81 (echo $?).

expected result:
./soffice.bin should keep running until it gets a SIGINT or SIGTERM.




Sadly there was no futher information about the crash. Neither via STDOUT/STDERR nor in ~/.config/libreoffice/4/crash/ (directory was totally empty). The only thing I can offer is the attached strace output.

But I was able to narrow down the problem to:
~/.config/libreoffice/4/user/extensions/buildid
Deleting that file triggers the problem.

Problem was reproducible on different openSUSE 42.2 (x86_64) computers with:
- https://downloadarchive.documentfoundation.org/libreoffice/old/5.3.3.2/rpm/x86_64/LibreOffice_5.3.3.2_Linux_x86-64_rpm.tar.gz
- openSUSE 42.2 LibreOffice: http://download.opensuse.org/update/leap/42.2/oss/src/libreoffice-5.2.5.1-18.3.2.src.rpm
Comment 1 duge 2017-05-17 15:06:11 UTC
supplement:

Bug is also triggered when updating LibreOffice.

E.g. 5.2.3.3 -> 5.2.5.1 which was recently delivered by openSUSE 42.2.
Comment 2 Xisco Faulí 2017-05-18 11:08:24 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: fo-FO (ca_ES.UTF-8); Calc: group

on Ubuntu 16.10
Comment 3 duge 2017-05-18 12:04:57 UTC
Reproduced with the following systems:

http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF/2017-05-17_23.34.19/master~2017-05-17_23.34.19_LibreOfficeDev_5.4.0.0.alpha1_Linux_x86-64_rpm.tar.gz
on openSUSE 42.2

http://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso (has LibreOffice 5.3.2.2)
Run livecd (I used Qemu/KVM) and do:
$ sudo zypper in libreoffice-writer
[...]
$ /usr/lib64/libreoffice/program/soffice.bin --headless
$ echo $?
81

ftp://mirror.23media.de/ubuntu-releases/17.04/ubuntu-17.04-desktop-amd64.iso
Run livecd (I used Qemu/KVM) and do:
$ /usr/lib/libreoffice/program/soffice.bin --headless
$ echo $?
81

----------

But I think I finally got the reason for this.

The bug only happends when calling ".../program/soffice.bin"

When calling ".../program/soffice" everything's fine.

I guess this is intended behavior!?
If yes, feel free to close / set to invalid.
Comment 4 Xisco Faulí 2017-05-18 12:42:01 UTC
yes, you need to use soffice without .bin. I don't know the technical reasons why but I know there's one ;-)
Closing as RESOLVED NOTABUG