Download it now!
Bug 107963 - FORMATTING: Styles can't be applied to text within a textbox
Summary: FORMATTING: Styles can't be applied to text within a textbox
Status: RESOLVED DUPLICATE of bug 111921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.6.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Styles Textbox
  Show dependency treegraph
 
Reported: 2017-05-19 20:23 UTC by Telesto
Modified: 2018-11-22 20:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-05-19 20:23:32 UTC
Description:
Styles can't be applied to text within a textbox

Steps to Reproduce:
1. Open Writer
2. Open styles and formatting sidebar (F11)
3. Insert a textbox (Insert -> Textbox) -> Styles and formatting will be empty (bug 107962)
4. Type something into the textbox and exit the textbox
5. Re-enter the textbox. Try to apply a template style

Actual Results:  
Style can't be applied

Expected Results:
Style should be applied, similar to Impress


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.5.0.0.alpha0+
Build ID: d57e6cd9dcc96112994ca2b14ac45896e86b26e5
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-05-18_22:43:07
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Thomas Lendo 2017-05-28 22:49:02 UTC
Reproduced.

Strange that nobody reported that bug since.

Version: 5.5.0.0.alpha0+
Build ID: 5c16d16ed3db32f922b2aeaad49592d2615c7e2c
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-26_23:00:41
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 2 Yousuf Philips (jay) (retired) 2017-05-29 23:57:20 UTC
Textboxes in Writer dont have the ability to have paragraph and character styles apply to it, so this is the correct behaviour. To be able to have styles applied to text in a textbox type object, insert a shape, and then add a textbox to it through the context menu.
Comment 3 Thomas Lendo 2017-05-30 21:34:03 UTC
A really weird and complicated way to have a text box with styles.
Comment 4 Regina Henschel 2018-11-22 20:41:28 UTC
It is a missing feature. There exist no reason, why the content of a text box cannot use custom defined styles. There exist a request in the meantime and therefore I set this to duplicate.

*** This bug has been marked as a duplicate of bug 111921 ***