Bug 108072 - FILEOPEN: Table in DOC with merged rows doesn't preserve setting that allows rows to break across pages
Summary: FILEOPEN: Table in DOC with merged rows doesn't preserve setting that allows ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Aron Budea
QA Contact:
URL:
Whiteboard: target:5.5.0 target:5.4.0.1 target:5.3.4
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks:
 
Reported: 2017-05-24 22:26 UTC by Aron Budea
Modified: 2017-06-01 08:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample for row break setting (28.00 KB, application/msword)
2017-05-24 22:26 UTC, Aron Budea
Details
Another sample that displays differently in Word and Writer (29.00 KB, application/msword)
2017-05-24 22:28 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-05-24 22:26:44 UTC
Created attachment 133545 [details]
Sample for row break setting

- Open the attached DOC.
- Right click in table, open Table Properties...
- On Text Flow tab take a look at setting "Allow row to break across pages and columns".

=> The tristate checkbox is in indeterminate state, meaning there are rows where the setting is enabled and where it's disabled (if you open the dialog after just clicking in a cell, the settings for the whole table are shown).
In Word the setting is enabled for the whole table.

In LO if you select a cell/row in the rows where cells are merged (rows 1-2), the setting is disabled instead of being enabled.
If you select a cell in the 3rd row, the setting is enabled as expected.

This only affects DOC files, DOCX format is imported fine.

Observed with LO 5.3.2.2 & 4.0.0.3 / Windows 7.
Comment 1 Aron Budea 2017-05-24 22:28:14 UTC
Created attachment 133546 [details]
Another sample that displays differently in Word and Writer

Added a bunch of lines in the sample to make it display differently in the two programs.
Comment 2 Aron Budea 2017-05-25 01:04:13 UTC
A note here, the setting "Allow row to break across pages and columns" is enabled by default in tables both in Writer and Word.
Comment 3 Aron Budea 2017-05-28 22:05:59 UTC
Apparently this is a regression since 4.3.
There was the following commit that eliminated the use of the obsolete sprmTFCantSplit90 property, but since the IDs were, and remained mixed up, it resulted in a regression:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=72ef0d88e916b320de85fe2ebf08cb7aea28ca08
author		Luke Deller <luke@deller.id.au>	2014-04-07 12:20:15 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2014-04-07 13:52:30 (GMT)

"Ignore sprmTFCantSplit90 in .doc file per MS spec"

Fix with unit test is now in gerrit.
Comment 4 Commit Notification 2017-05-31 11:47:27 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0e12738449063abd9aad34ef78d26183ff11d6a

tdf#108072: match sprmTFCantSplit with its correct id

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-05-31 13:26:38 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6c6d3efdd5dcb81e6536899896358f054563c7eb&h=libreoffice-5-4

tdf#108072: match sprmTFCantSplit with its correct id

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Aron Budea 2017-05-31 13:49:26 UTC
Fix for 5.3 is in gerrit.
Comment 7 Commit Notification 2017-05-31 16:05:35 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7dcd949536eca604b86f1c8d906339e7cd49319d&h=libreoffice-5-3

tdf#108072: match sprmTFCantSplit with its correct id

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2017-06-01 08:42:55 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2017-06-01 08:53:39 UTC Comment hidden (obsolete)