Download it now!
Bug 108092 - FILEOPEN: DOCX: Paragraph alignment from text box is incorrect (affects rotated text vertical position)
Summary: FILEOPEN: DOCX: Paragraph alignment from text box is incorrect (affects rotat...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox DOCX-Paragraph
  Show dependency treegraph
 
Reported: 2017-05-25 21:24 UTC by Mikhail Novosyolov
Modified: 2019-07-11 12:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
problematic document (MSO 2013) (160.98 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-05-25 21:24 UTC, Mikhail Novosyolov
Details
screenshot of how it is displayed and how it must be (196.73 KB, image/png)
2017-05-25 21:44 UTC, Mikhail Novosyolov
Details
Minimal file with issue reproduction (14.10 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-05-28 21:58 UTC, Bartosz
Details
Screenshot of the original document side by side in Word and Writer master (210.53 KB, image/png)
2019-07-11 12:10 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Novosyolov 2017-05-25 21:24:43 UTC
Created attachment 133582 [details]
problematic document (MSO 2013)

In the attached document the text is alligned incorrectly in vertical boxes in the bottom of the document.

The arrows (figures) are located incorrectly in LO 5.3.3, but it is fixed in 5.4.
Comment 1 Xisco Faulí 2017-05-25 21:41:01 UTC Comment hidden (obsolete)
Comment 2 Mikhail Novosyolov 2017-05-25 21:42:27 UTC Comment hidden (obsolete)
Comment 3 Mikhail Novosyolov 2017-05-25 21:44:40 UTC
Created attachment 133587 [details]
screenshot of how it is displayed and how it must be
Comment 4 Xisco Faulí 2017-05-26 15:12:09 UTC
Ouch, you're right. I misunderstood you.

Confirmed in

Version: 5.4.0.0.alpha1+
Build ID: 74d2e606fd3605fe0a585f596eaa215ae4e20d18
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); Calc: group

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

and

Version: 4.2.0.0.alpha0+
Build ID: 2b0320da7b59d2d4c0c5dc5da8424458ce0d819d

in 

 LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

text is not even imported
Comment 5 Mikhail Novosyolov 2017-05-26 17:30:52 UTC Comment hidden (no-value)
Comment 6 Mikhail Novosyolov 2017-05-26 17:42:25 UTC Comment hidden (no-value)
Comment 7 Bartosz 2017-05-28 21:58:23 UTC
Created attachment 133680 [details]
Minimal file with issue reproduction
Comment 8 Mikhail Novosyolov 2017-07-31 08:35:48 UTC Comment hidden (no-value)
Comment 9 Timur 2017-08-22 14:44:02 UTC
Bugzilla is "issue based", so a single issue must be pointed at, after a search for not being a duplicate. And that's vertical alignment here.
Bugzilla is not "document based", like "this document doesn't display nice" or "it's also slow". Please search see other bugs, there are multiple perf. bugs for 5.3 like Bug 108574 for Writer and few for Calc.

As for vertical alignment, this is text box in MSO where text is rotated in text box and then centered in paragraph. 
LO somehow takes "centered in paragraph" as horizontal in frame, instead of setting vertical for vertical text.
Comment 10 Mikhail Novosyolov 2017-08-23 21:30:11 UTC
Timur, that's great, but there is lack of a manual which would describe how to investigate the reason of the issue.
Comment 11 QA Administrators 2018-08-29 02:41:25 UTC Comment hidden (obsolete)
Comment 12 Gabor Kelemen 2019-07-11 12:10:14 UTC
Created attachment 152722 [details]
Screenshot of the original document side by side in Word and Writer master

Text box text alignment is now looking quite similar to Word in: 

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 49422a469646ad8be43ba828ca24c2484c26b9e8
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-08_00:50:19
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

But not in 6.3 beta1
Comment 13 Gabor Kelemen 2019-07-11 12:13:28 UTC
I guess this can be set to WFM thanks to all the recent BTLR work from Miklos.