Bug 108187 - Impress is crashing when add interaction to shape
Summary: Impress is crashing when add interaction to shape
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5.3.4
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2017-05-28 05:53 UTC by Khalil
Modified: 2017-08-05 17:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress error (11.43 KB, image/png)
2017-05-28 05:53 UTC, Khalil
Details
gdb backtrace (36.65 KB, text/plain)
2017-05-31 12:04 UTC, Xisco Faulí
Details
bt with debug symbols (kde4) (3.02 KB, text/plain)
2017-06-01 21:00 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Khalil 2017-05-28 05:53:07 UTC
Created attachment 133659 [details]
Impress error

When you add shape in Impress, then add interaction , Go to document, then select MSO files DOCX, XLSX, PPTX Impress crashed with fatal error could not open storage.
Attached error snap
Comment 1 Xisco Faulí 2017-05-31 11:57:38 UTC
Steps:
1. Open Impress
2. Insert a Shape
3. Right Click - Interaction
4. Select 'Go to Document'
5. Select a .Docx file

Version: 5.5.0.0.alpha0+
Build ID: 9956849c2ea6049582e2ccf04c355542c1ef00a1
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Xisco Faulí 2017-05-31 12:04:29 UTC
Created attachment 133742 [details]
gdb backtrace
Comment 3 Julien Nabet 2017-06-01 21:00:00 UTC
Created attachment 133792 [details]
bt with debug symbols (kde4)

On pc Debian x86-64 with master sources updated today, I could reproduce this.
I gave a try with kde4 rendering, there's a crash to display the error message.
Comment 4 Julien Nabet 2017-06-01 21:01:11 UTC
Caolán: thought you might be interested in this one.
It seems there are at least 2 pbs since there's a crash to display error popup with kde4 rendering + a crash after having displaying the popup with gtk3
Comment 5 Caolán McNamara 2017-06-02 11:04:05 UTC
The eventual crash in ShowNativeErrorBox is triggered by an unhandled exception so the fix is typically to catch the exception in the right place (in gdb "catch throw" and "catch catch" after setting up to the last point before the interaction that will make it crash and examine the callstacks one by one)
Comment 6 Commit Notification 2017-06-02 11:25:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=70c477e80bb0b345f64c54cae681f7eba12a7968

Resolves: tdf#108187 fatal exception on testing if ooxml is a odf

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2017-06-02 11:25:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57ccbbc1bae230b9f03f808d8b5d363f22fa1b25&h=libreoffice-5-4

Resolves: tdf#108187 fatal exception on testing if ooxml is a odf

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2017-06-02 11:26:24 UTC
backport to 5-3 in gerrit
Comment 9 Julien Nabet 2017-06-04 12:54:27 UTC
With master sources updated today, I don't reproduce this.
Thank you Caolán!
Comment 10 Commit Notification 2017-06-14 08:18:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e0e1facbdf1c4a2a3db253aa39c6253506a2f1b&h=libreoffice-5-3

Resolves: tdf#108187 fatal exception on testing if ooxml is a odf

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Julien Nabet 2017-06-14 08:36:32 UTC
For marketing reason, there's a jump on release versionning, so there won't be 5.5.0 version :-(
Fix target field accordingly.
Comment 12 Commit Notification 2017-06-14 21:13:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=285f17f8b67c40b115fa7411745e339237483f0e&h=libreoffice-5-3-4

Resolves: tdf#108187 fatal exception on testing if ooxml is a odf

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.