Bug Hunting Session
Bug 108242 - LibreOffice windows do not respond when moved to second screen
Summary: LibreOffice windows do not respond when moved to second screen
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor
  Show dependency treegraph
 
Reported: 2017-05-30 09:40 UTC by Dirk
Modified: 2017-11-13 18:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk 2017-05-30 09:40:02 UTC
Description:
I use OS X 10.10.5 Yosemite and I have the problem still some time, that all windows of LibreOffice that I have dragged to my second screen does not work. They does not respond to mouse clicks and keystrokes. If I try to resize the window at the second screen it jumps to the first screen and resizes there. Simple moving the window at the second screen works.

If I drag the window back to my first screen (from MacBook) the window works again. But then I have often the problem, that all mouse clicks are shifted some centimeters away from the current position of the mouse cursor. That means, if I try to click into one cell (in Calc) a cell nearly six cells away gets the focus.

Steps to Reproduce:
1. Plug in a second screen.
2. Open one LibreOffice window of Calc, Writer, ...
3. Drag the window to the second screen

Actual Results:  
The window at the second screen does not respond to keystrokes or mouse clicks and resizing is not possible.

Expected Results:
The window behaves at the second screen like it does at the first screen.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 Dirk 2017-05-30 09:46:44 UTC
LibreOffice 5.3.3.2 has the same problems. Maybe some of the latest OS X security updates causes this problem, because LibreOffice has worked fine for a very long time.
Comment 2 Alex Thurgood 2017-06-12 08:01:17 UTC
@Dirk : please provide more information on your hardware setup :

- screen resolution of second screen
- model and type of screen
- how you have set up the connection to the second screen from your Mac
Comment 3 Dirk 2017-06-26 07:51:07 UTC
My screen resolutions at the MacBook is 2880 x 1800 Retina and at the Samsung LS27E391H 1920 x 1080 @ 60Hz (1080p). I connect the second monitor via HDMI.

I can not say since when, but now it works again. I can use the LibreOffice window at both screens as expected. Unfortunately, I can not say if any update or other action could be the reason for this.
Comment 4 Xisco Faulí 2017-11-13 18:00:29 UTC
(In reply to Dirk from comment #3)
> My screen resolutions at the MacBook is 2880 x 1800 Retina and at the
> Samsung LS27E391H 1920 x 1080 @ 60Hz (1080p). I connect the second monitor
> via HDMI.
> 
> I can not say since when, but now it works again. I can use the LibreOffice
> window at both screens as expected. Unfortunately, I can not say if any
> update or other action could be the reason for this.

Closing as RESOLVED WORKSFORME then