Download it now!
Bug 108255 - "Remove Border" checkbox adds confusion, but no functionality
Summary: "Remove Border" checkbox adds confusion, but no functionality
Status: RESOLVED DUPLICATE of bug 87787
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Borders-Tab
  Show dependency treegraph
 
Reported: 2017-05-30 23:32 UTC by Kevin
Modified: 2017-08-08 12:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
steps and demo included within spreadsheet (10.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-30 23:32 UTC, Kevin
Details
two borders from adjacent cells (8.15 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-05-31 22:28 UTC, Regina Henschel
Details
rebuttal using two-borders spreadsheet (13.16 KB, image/jpeg)
2017-06-01 03:53 UTC, Kevin
Details
another rebuttal (12.15 KB, image/jpeg)
2017-06-01 03:57 UTC, Kevin
Details
further evidence (11.29 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-02 00:00 UTC, Kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin 2017-05-30 23:32:02 UTC
Description:
"Remove Border" checkbox adds confusion, but no functionality.

Steps to Reproduce:
0. open attached spreadsheet
1. select D2 and choose Format Cells/Borders
observe: the left border is shown
2. click twice to remove the border (note that the first click goes to a grey border – which is a useless click as far as I can see – what's the difference between that and the black border display?)
3. click to check the Remove Border checkbox and okay the dialog
observe: the border is gone – as desired
4. undo to restore the border and repeat steps 2 & 3 but this time, do NOT check the Remove Border checkbox
observe: same result – the border is removed – the state of the Remove Border checkbox is irrelevant – wasted clicks, confusing learning curve
5. undo to restore the border
6. select Cell C2 and enter the Format Cells/Border dialog
observe: the right border is not displayed and the Remove Border checkbox is greyed out and cannot be made active

Conclusion: Calc is grossly inferior to Excel in terms of user-friendly control of borders and to add insult to injury, it adds a whole useless layer with this checkbox that serves only to confuse. To add further insult, this checkbox has been renamed since 5.2, teasing the user with the idea that this long-standing flaw has been addressed.


Actual Results:  
(see "observe" above)

Expected Results:
Calc should not be less powerful or harder to use than Excel.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Kevin 2017-05-30 23:32:44 UTC
Created attachment 133736 [details]
steps and demo included within spreadsheet
Comment 2 Regina Henschel 2017-05-31 22:28:15 UTC
Created attachment 133762 [details]
two borders from adjacent cells

The checkbox is not for the cell itself, but for the adjacent cell; as its label says. In Calc borders always collapse. That means, if B2 has a right border and C2 has a left border, only one is shown. In case that the border of C2 is thicker than the border of B2, the border of C2 is shown.

When you now remove this border without checking "Remove Borders", the border from the cell B2 is still there and is visible now. If the option is checked, both borders are removed.
Comment 3 Kevin 2017-05-31 22:44:28 UTC
> The checkbox is not for the cell itself, but for the adjacent cell; as its
> label says. In Calc borders always collapse. That means, if B2 has a right
> border and C2 has a left border, only one is shown. In case that the border
> of C2 is thicker than the border of B2, the border of C2 is shown.
> 
> When you now remove this border without checking "Remove Borders", the
> border from the cell B2 is still there and is visible now. If the option is
> checked, both borders are removed.

If you follow the steps in the spreadsheet, you'll see how broken this all is.

To review: 

1. C2 has no border; D2 has a left border
2. If you click twice to remove D2's left border (why does it first cycle through a deceptive and apparently meaningless grey border designation?), the Remove Border checkbox becomes active! (Why does it become active if there's no such border to remove?)
3. If you try to do this from Cell C2, where the Remove Border checkbox would actually be useful, there's no way to make it active so it can be used to remove the unwanted border from the adjacent D2.

THE FUNDAMENTAL QUESTION: Why did you implement it differently from Excel? There's nothing to gain except confusion, frustration and extra clicks.

4. Try adding a red right border to C2 - you can't even see it unless you remove the white border from D2. So you're saying that the point of having the Remove Border checkbox is to allow you to remove a currently invisible border that you just happen to remember was there underneath the one you see?

This, combined with the "red-green-blue" problem where selected text is automatically changed because of parameters of unselected text, makes the program incredibly painful to use.
Comment 4 Kevin 2017-05-31 22:51:16 UTC
Okay - so are you saying that this adds functionality beyond Excel in that you can have two borders of different thickness or color between two adjacent cells? It's true that Excel allows only one border between cells, but let's try this "feature not a bug" and see what it can do:

Give C2 a thicker red right border, leaving the thinner white left border in D2 - the D2 border is invisible. In no cases can you actually see two borders, so where's the functionality that you seem to be saying justifies the crippling effects on the user who simply wants to quickly and intuitively add or remove borders?
Comment 5 Kevin 2017-05-31 22:53:00 UTC
Even if I'm missing some functionality that this provides, it's a terrible price to pay for the elegant solution of having a single border that can be controlled from either cell that uses it. If nothing else, there should be a Options checkbox for "allow/disallow" double borders.
Comment 6 Kevin 2017-06-01 03:48:56 UTC
Every time you click a cell with an unwanted border that Calc has forced to have a parent cell (as opposed to Excel, which allows the border to simply exist and be accessed from any adjacent cell) ... every time you do this, you have to click FOUR TIMES:

1. once to make the border grey
2. once to make the border go away
3. once on Remove Border, just in case there's another temporarily invisible border parented by the adjacent cell
4. once to OK the dialog
Comment 7 Kevin 2017-06-01 03:53:37 UTC
Created attachment 133767 [details]
rebuttal using two-borders spreadsheet

This is a screenshot zooming in on your 1008255-two borders.ods file.

Yes, C2 has a right red border, but you can't see it! What's the functionality of that? All it does is cause trouble and extra work. If you paste the cell elsewhere to try to save time by copying its internal formatting, the red border pops up out of nowhere, always unwanted. You've added a "feature" that has no function, that violates the learning curve almost all of your users have traversed with Excel, and that causes many extra clicks at best and utter confusion at worst.

C2 should be an object; C3 should be an object; and the vertical border between them should be a single object, not two objects with different parents, only one of which can be viewed.
Comment 8 Kevin 2017-06-01 03:57:52 UTC
Created attachment 133768 [details]
another rebuttal

This one is zoomed all the way in. Look carefully - there's a vertical black selection line running dead-center between B2 and C3. If there were any point to having B2's right border and C3's left border be discrete objects, the area to the left of black central selection line would be red and you'd see a border that's half red and half blue - that would at least let you do something Excel can't do - although I'm not sure why you'd want to do that and I'd much rather have the ease of controlling a single border. But you can't do that! The red border is there, as a ghost, invisible, but waiting to cause trouble.
Comment 9 Kevin 2017-06-02 00:00:37 UTC
Created attachment 133794 [details]
further evidence
Comment 10 Kevin 2017-06-02 22:54:58 UTC
I have a new understanding of this bug. The problem is that when you are in one cell, Calc is blind to the attributes of the adjacent cell. This explains the two major symptoms:

1. Calc fails to activate the Remove Border checkbox when there is indeed a border available to be removed, forcing the user to enter the other cell. Calc can't put up the Remove Borders checkbox unless there is ALSO a pre-existing border in the selected cell. Adding a border while in the dialog box does not accomplish this.

2. Calc fails to grey out the Remove Border checkbox when there is no border available to be removed, causing extra clicks and extreme frustration.

SOLUTION 1 (best): Make it work like Excel - each border is a discrete object, not parented by any cell, but accessible from any cell on which it borders.

SOLUTION 2 (if you insist that there is some value to giving each cell its own discrete set of borders): Give Calc the intelligence to examine the adjacent cells and activate the Remove Border checkbox only if there's a border to be removed.

A whole college course in UI Design could be dedicated to the Format Cells design of Calc, and another course could be dedicated to the different, but even more appallingly embarrassing design failures of Excel. Surely there is someone at the Document Foundation with the vision and perseverance to fix this mess once and for all.
Comment 11 Jacques Guilleron 2017-06-07 16:20:17 UTC
Hi Kevin,

In attachment 133794 [details], 108276 and 108255.ods, try:
Select C5:C6, right click, next Format Cells, 2 clicks on central line to delete it.

Gray lines mean those lines were not modify.
See: https://help.libreoffice.org/Calc/User_Defined_Borders_in_Cells

Jacques
Comment 12 Jacques Guilleron 2017-06-07 18:42:50 UTC
In the previous comment, Please read : 
"Gray lines mean those lines will not be modified."
Thank you,
Comment 13 Kevin 2017-06-07 19:35:16 UTC
(In reply to Jacques Guilleron from comment #12)

1. If C5 has a right border and C6 has no borders, there is often no way to remove the border while in Format Cells for C6.

2. The Remove Border checkbox often appears when checking it will do nothing

3. The Remove Border checkbox often fails to appear when the user wants to use it to remove the border of an adjacent cell

4. The grey line often appears in situations where it makes no difference when you leave it or remove it and you still have to click through the grey line state to get to the desired state even though there's no reason to make the user do so.

Bottom Line: The UI for borders is embarrassing, wrong, buggy, hostile, and is ruining the reputation of Calc and Document Foundation. You're make people hate you just like Excel makes us hate Microsoft. The whole point of this project is to answer the public outcry against the flaws of the Excel interface. Borders is a case where Document Foundation is making it worse - MUCH MUCH worse!
Comment 14 Kevin 2017-06-07 19:38:45 UTC
None of the other people assessing this report have spent two months, 8 hours a day, seven days a week, USING Calc to work on a spreadsheet that relies intensely on borders, backgrounds and font changes to present its data. I have - I am - you are not - by the time you read this I will have hit all of the problems I've reported at least 100 more times. I'm not arguing about the theory of the interface. I'm USING the interface. And it ... is ... broken. Before I spent 8 hours a day with Calc, I spent 8 hours a day doing exactly the same procedures with Excel. I'm living this nightmare.
Comment 15 Buovjaga 2017-06-10 17:39:21 UTC
UX: isn't this included in the idea of bug 87787?
Comment 16 Heiko Tietze 2017-06-12 06:51:56 UTC
(In reply to Buovjaga from comment #15)
> UX: isn't this included in the idea of bug 87787?

Haven't read every comment, but here is a link to the help: https://help.libreoffice.org/Calc/User_Defined_Borders_in_Cells (it's similar in Excel but you cannot active this "indetermined" state)

Closing the ticket as duplicate of bug 87787 makes sense to me but is better done by Kevin. I suggest to add a short summary from this thread there.
Comment 17 Heiko Tietze 2017-08-08 12:37:08 UTC

*** This bug has been marked as a duplicate of bug 87787 ***