Bug Hunting Session
Bug 108370 - Impress Crash with videos
Summary: Impress Crash with videos
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks: Media
  Show dependency treegraph
 
Reported: 2017-06-06 17:05 UTC by Ale
Modified: 2018-06-02 17:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Asked file for the test (2.97 MB, application/vnd.oasis.opendocument.presentation)
2017-06-26 12:05 UTC, Ale
Details
GDB trace of crash with master (25.97 KB, text/plain)
2017-06-28 10:33 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ale 2017-06-06 17:05:14 UTC
If you try to add a video on impress you can go over it, but if you go back on the slides when you go back on the video slide impress crash, blocks itself and you have to force the closing.
It happens with all videos, on windows and on linux ubuntu too
Comment 1 Xisco Faulí 2017-06-06 17:13:56 UTC
Thank you for reporting the bug.
I can't reproduce it in

Version: 5.5.0.0.alpha0+
Build ID: f2d40b8ba172d90be9a43c30cd5cbd62c0e8e548
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Ale 2017-06-26 12:05:25 UTC
Created attachment 134286 [details]
Asked file for the test

I tested it on windows with the new version 5.3.4 released today. Go to the last slide, on presentation mode, than try to go to the first one. When you try to go back again from the video to the 1st the program frooze.

It happens also on linux, using a Kubuntu 16.04 but on linux sometimes the program dont crash....but it becames slower , other times crashes
Comment 3 Xisco Faulí 2017-06-26 15:13:10 UTC
I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

nor in

Version: 6.0.0.0.alpha0+
Build ID: cb37c5f0f3de7b545231a53d46a5271058af76ad
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-23_06:55:41
Locale: es-ES (es_ES); Calc: group

Do you have OpenGL enabled ?
Comment 4 Buovjaga 2017-06-26 18:22:43 UTC
Ale: yep, copy and paste the text from your Help - About window.

Also, you could try getting a backtrace: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux
Comment 5 Ale 2017-06-27 21:24:45 UTC
Versione: 5.3.4.2 (x64)
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Thread CPU: 4; Versione SO: Windows 6.19; Resa interfaccia: predefinito; Motore layout: nuovo; 
Versione locale: it-IT (it_IT); Calc: group


Hum no in the options i dont have OpenGL
https://s13.postimg.org/xdk6oozwn/Immagine.png
Comment 6 Ale 2017-06-27 21:30:24 UTC
I have a new info
It seems that it happens when i move forward and then back with the mouse wheel
if i use the arrows on the keybord seems to work and crash more more less
Comment 7 Xisco Faulí 2017-06-28 09:55:19 UTC
Still no reproducible using the mouse wheel with the builds mentioned in comment 3
Comment 8 Buovjaga 2017-06-28 10:33:01 UTC
Created attachment 134341 [details]
GDB trace of crash with master

GDB dropped out already when I mouse-wheeled to the third slide.

Without GDB I repro with the original steps

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: f808c50c6eece87d515df3b84b1c774395b5d9bc
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 26th 2017

Also crashes on Win
Version: 5.4.0.1 (x64)
Build ID: 962a9c4e2f56d1dbdd354b1becda28edd471f4f2
CPU threads: 4; OS: Windows 6.19; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group
Comment 9 Xisco Faulí 2017-06-28 10:56:36 UTC
Moving to NEW then...
Comment 10 Buovjaga 2017-06-28 11:15:47 UTC
It does not crash in
LibreOffice 3.5.7.2 
Build ID: 350m1(Build:2)

Tested under Ubuntu 12.04 to get the authentic experience. Note that to play the vid one has to install gstreamer0.10-ffmpeg package.
Comment 11 Ale 2017-06-28 11:54:14 UTC Comment hidden (obsolete)
Comment 12 Buovjaga 2017-06-28 12:11:57 UTC Comment hidden (obsolete)
Comment 13 Ale 2017-06-28 14:07:29 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2017-06-28 15:09:21 UTC Comment hidden (obsolete)
Comment 15 Buovjaga 2018-05-29 18:58:40 UTC
Ale: the crashing stopped for me. Can you test with 6.0.4?

Arch Linux 64-bit
Version: 6.0.4.2
Build ID: 6.0.4-1
CPU threads: 8; OS: Linux 4.16; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 16 Buovjaga 2018-06-02 17:50:44 UTC
No response, so closing as WFM.