Bug 108417 - FILEOPEN DOCX Some embedded Arabic fonts are substituted
Summary: FILEOPEN DOCX Some embedded Arabic fonts are substituted
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Font-Substitution DOCX Fonts-Embedded
  Show dependency treegraph
 
Reported: 2017-06-08 15:13 UTC by kavalec74
Modified: 2022-11-27 04:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
docx with embeded / incrusted fonts (32.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-06-08 15:13 UTC, kavalec74
Details
This is a screenshot of MS-Office (40.95 KB, image/jpeg)
2017-06-12 22:02 UTC, kavalec74
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kavalec74 2017-06-08 15:13:09 UTC
Created attachment 133917 [details]
docx with embeded / incrusted fonts

Some arabic fonts does not display. Check the attached file docx for comparison.
Comment 1 Buovjaga 2017-06-11 13:57:44 UTC
How should they look? Please attach screenshot of correct rendering.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the screenshot.
Comment 2 kavalec74 2017-06-12 22:02:08 UTC
Created attachment 133987 [details]
This is a screenshot of MS-Office

This is a screenshot from how it looks like in MS-Office´s Word.
Comment 3 Buovjaga 2017-06-15 16:10:41 UTC
Have you checked that the fonts allow embedding? You have some MS Office fonts in there. Maybe they do not allow it? Right-clicking the font file and Properties might give information.
Comment 4 kavalec74 2017-06-15 22:42:50 UTC
Yes, the fonts are embedded in the docx file. I checked it in another PC, where these fonts are not installed. Please check the docx yourself.
Comment 5 Buovjaga 2017-06-16 04:21:12 UTC
(In reply to kavalec74 from comment #4)
> Yes, the fonts are embedded in the docx file. I checked it in another PC,
> where these fonts are not installed. Please check the docx yourself.

That's not what I asked. Please check, if the font files allow embedding. Go to your fonts folder, find the files, right-click, properties, examine the data.
Comment 6 Buovjaga 2017-06-16 04:22:03 UTC
(In reply to Buovjaga from comment #5)
> (In reply to kavalec74 from comment #4)
> > Yes, the fonts are embedded in the docx file. I checked it in another PC,
> > where these fonts are not installed. Please check the docx yourself.
> 
> That's not what I asked. Please check, if the font files allow embedding. Go
> to your fonts folder, find the files, right-click, properties, examine the
> data.

I am asking, because LibreOffice displays some of them as substituted.
Comment 7 Buovjaga 2017-06-16 05:47:14 UTC
Well, I guess I was being a bit silly as the fonts really are in there (as can be seen by extracting the .docx as zip). Now I checked on Windows and Andalus can indeed be embedded (it says "Editable").

Earlier I tested on Linux and confirm all the fonts on Linux were substituted.

Win 7 Pro 64-bit Version: 6.0.0.0.alpha0+ (x64)
Build ID: a1ace08b5b86a76e7275dcef2545a7d52ae2ed2d
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-13_03:04:47
Locale: fi-FI (fi_FI); Calc: CL

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 8 QA Administrators 2019-05-01 02:45:46 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2021-05-01 03:56:40 UTC Comment hidden (obsolete)
Comment 10 خالد حسني 2022-11-27 04:53:10 UTC
The embedded fonts in this document has restricted rights and so we reject them and use substitute fonts. And even if we skipped that, most of the fonts are actually empty so they are rather unusable, the rest are subsetted so also unusable. May be we should add an info bar informing the user that the document has embedded fonts but we are not using them, but this would be a separate enhancement.
Comment 11 خالد حسني 2022-11-27 04:54:46 UTC
(In reply to خالد حسني from comment #10)
> May be we should add an info bar informing the user that
> the document has embedded fonts but we are not using them, but this would be
> a separate enhancement.

This is already tracked in bug 145967.