Bug 108457 - Android 4.4: crash when open odp file
Summary: Android 4.4: crash when open odp file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2017-06-11 08:00 UTC by raal
Modified: 2020-06-23 06:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test file (9.30 KB, application/vnd.oasis.opendocument.text)
2017-06-11 08:01 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2017-06-11 08:00:44 UTC
Description:
Android 4.4  crashes when open odp file.No crash in android 5.1.1
log:
*** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
Build fingerprint: 'Xiaomi/mocha/mocha:4.4.4/KTU84P/6.4.14:user/release-keys'
Revision: '0'
pid: 29152, tid: 29211, name: Thread-1507  >>> org.example.libreoffice <<<
signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr fff104fb
    r0 76065b67  r1 7da08408  r2 6f75746c  r3 fff104bf
    r4 7d412874  r5 7d413218  r6 7d9d0300  r7 7d4126b0
    r8 7d41494c  r9 7da012a0  sl 7d9d0d28  fp 7d9fd940
    ip 00000000  sp 7d4126b0  lr 75bd71e9  pc 75bd7172  cpsr a0030030
    d0  0000008000000001  d1  0000000000000000
    d2  0000010000030000  d3  0001000100000000
    d4  4066c00000000000  d5  4047800000000000
    d6  4744e00045e10000  d7  0000000000000000
    d8  4036000000000000  d9  4063200000000000
    d10 0000000000000000  d11 0000000000000000
    d12 0000000000000000  d13 0000000000000000
    d14 0000000000000000  d15 0000000000000000
    d16 4036000000000000  d17 4036000000000000
    d18 4036000000000000  d19 4082c00000000000
    d20 7fefffffffffffff  d21 0000000000000000
    d22 0010001000100010  d23 0000000100000001
    d24 4036000000000000  d25 0000005f0000005d
    d26 0707070703030303  d27 017a000001720000
    d28 014a005301420051  d29 015a005701520055
    d30 016a005b01620059  d31 017a005f0172005d
    scr 60000013

backtrace:
    #00  pc 0234f172  /data/app-lib/org.example.libreoffice-2/liblo-native-code.so
    #01  pc 0234f1e5  /data/app-lib/org.example.libreoffice-2/liblo-native-code.so

code around pc:
    75bd7150 617b3094 68bbe009 f1076c9a 68f80314 
    75bd7160 461a4611 feb8f7ff 230761b8 e01861fb 
    75bd7170 6bdc69bb 68b969b8 2300687a 61f847a0 
    75bd7180 2b0069fb 69fbd012 2b13b2db 68bbd10e 
    75bd7190 f1076c9a 68f80314 461a4611 fe9cf7ff 
    75bd71a0 69bb61b8 d1e32b00 bf00e000 461869fb 
    75bd71b0 46bd3724 bf00bd90 b084b580 6078af00 
    75bd71c0 687b6039 d0032b00 685b687b d1012b00 
    75bd71d0 e00b2306 685b687b 685b6e1b 68f860fb 
    75bd71e0 683a6879 ff94f7ff bf004603 37104618 
    75bd71f0 bd8046bd b086b580 6078af00 689b687b 
    75bd7200 687b617b 613b681b 685b687b 68fb60fb 
    75bd7210 d0092b00 f8d368fb 687b20a0 d103429a 
    75bd7220 220068fb 20a0f8c3 681b687b f003681b 
    75bd7230 2b000302 6878d002 ff28f7ff 681b687b 
    75bd7240 f003681b 2b000301 6878d002 fb9cf7fd 

code around lr:
    75bd71c8 685b687b d1012b00 e00b2306 685b687b 
    75bd71d8 685b6e1b 68f860fb 683a6879 ff94f7ff 
    75bd71e8 bf004603 37104618 bd8046bd b086b580 
    75bd71f8 6078af00 689b687b 687b617b 613b681b 
    75bd7208 685b687b 68fb60fb d0092b00 f8d368fb 
    75bd7218 687b20a0 d103429a 220068fb 20a0f8c3 
    75bd7228 681b687b f003681b 2b000302 6878d002 
    75bd7238 ff28f7ff 681b687b f003681b 2b000301 
    75bd7248 6878d002 fb9cf7fd 69db693b d0032b00 
    75bd7258 69db693b 47986878 68796978 fa1cf003 
    75bd7268 607b2300 46bd3718 bf00bd80 b088b580 
    75bd7278 6078af00 23006039 687b61bb d1012b00 
    75bd7288 e0c82321 2b00683b 2306d101 683be0c3 
    75bd7298 2307691a 0302f2c0 dd01429a e0ba2304 
    75bd72a8 61fb2300 687ae023 330469fb 4413009b 
    75bd72b8 61bb685b 681b69bb 683b689a 4610689b  

Steps to Reproduce:
1. open attached file in android 4.4


Actual Results:  
crash

Expected Results:
no crash


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Comment 1 raal 2017-06-11 08:01:40 UTC
Created attachment 133952 [details]
test file
Comment 2 Xisco Faulí 2017-06-11 13:28:57 UTC
@Ximeng, @Gautam, one for you?
Comment 3 Xisco Faulí 2017-09-11 08:42:34 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 4 Xisco Faulí 2017-12-14 11:59:56 UTC
Hi raal, is it fixed in https://dev-builds.libreoffice.org/daily/master/android-test/ ?
Comment 5 raal 2017-12-14 18:20:31 UTC
(In reply to Xisco Faulí from comment #4)
> Hi raal, is it fixed in
> https://dev-builds.libreoffice.org/daily/master/android-test/ ?

No, unfortunately not. Works in android 5.0, but crashes in android 4.4
Comment 6 QA Administrators 2018-12-15 03:56:16 UTC Comment hidden (obsolete)
Comment 7 Michael Weghorn 2020-04-08 09:39:28 UTC
Does the issue still appear with a current daily build?
Comment 8 baffclan 2020-06-23 04:37:14 UTC
Cannot reproduce with Android-ARM@86-TDF.

Version: 7.1.0.0.alpha0+
Builed ID: 642fc41
Comment 9 Michael Weghorn 2020-06-23 06:03:16 UTC
Thanks for testing. Let's close as WORKSFORME.