Bug 108469 - 'As Character' image disappears after another image is inserted
Summary: 'As Character' image disappears after another image is inserted
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:5.4.0.1 target:5.3.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2017-06-11 20:54 UTC by Xisco Faulí
Modified: 2017-07-07 16:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
image (334.16 KB, image/png)
2017-06-11 20:54 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-06-11 20:54:36 UTC
Created attachment 133958 [details]
image

Steps to reproduce:
1. Open Writer
2. Open the attached image with a third program
3. Copy the image and paste it in Writer
4. Right Click - Anchor - As Character
5. Press enter and insert a line
6. Paste the same image again.

Observed behaviour: First image disappears. If you undo the last past, the first image is gone.

Reproduced in

Version: 5.5.0.0.alpha0+
Build ID: 6ab249ea6aecef5d3f35d624622a368061cad9c3
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-06-11 20:59:24 UTC
Regression introduced by:

author	Bjoern Michaelsen <bjoern.michaelsen@canonical.com>	2014-03-15 15:25:41 (GMT)
committer	Björn Michaelsen <bjoern.michaelsen@canonical.com>	2014-03-17 10:01:32 (GMT)
commit	72a4987434368bfb0b15f5ebb70a52108d349d5f (patch)
tree	f5767ba202a9b89487b79aa66f055d727549f56b
parent	5dc13b2d68eb30417f706935016d8bf7182b4aaa (diff)
fdo#47355: partially revert c5a8a2c3cbcee0175127a0662e3d820ea4deea22
- that commit claimed to fix i#84870
- however that example document _still_ loops for me on current master
  even with the change
- this caused the fdo#47355 regression in addition
- thus reverting to heal fdo#47355, expecting i#84870 unchanged as broken
  before and in need of a proper fix

Bisected with bibisect-43max

Adding Cc: to Bjoern Michaelsen
Comment 2 m.a.riosv 2017-06-11 21:25:53 UTC
Version: 5.4.0.0.beta2 (x64)
Build ID: 3cc1cdd8ee50f144e5514da51800a08119754d8f
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
Locale: es-ES (es_ES); Calc: CL
Version: 5.5.0.0.alpha0+
Build ID: 74d9b711d71cbaf4f853559211f6525db4a4b5db
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-08_02:48:15
Locale: es-ES (es_ES); Calc: CL

It seems only one image but looking with the navigator there are two, one over the other.

Seems the issue is it's inserted on the same place of the last image not where the cursor is.
Comment 3 Xisco Faulí 2017-06-12 16:16:02 UTC
Patch submitted to gerrit: https://gerrit.libreoffice.org/#/c/38705/
Comment 4 Commit Notification 2017-06-14 08:42:18 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3919d87210ea12ed3166c649ac52730026db01a4

tdf#104640, tdf#108469: Insert image where the cursor is

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-06-15 21:17:58 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63399341002c8a88ab58add99707fbef24210576&h=libreoffice-5-4

tdf#104640, tdf#108469: Insert image where the cursor is

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-07-07 16:37:10 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f44f65019a60b5bd70b08eb11db8d1baf4f6e229&h=libreoffice-5-3

tdf#104640, tdf#108469: Insert image where the cursor is

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.