Bug 108484 - VIEWING: The text is re-positioning when scrolling up an down if the automatic Spell Checking is enabled
Summary: VIEWING: The text is re-positioning when scrolling up an down if the automati...
Status: RESOLVED DUPLICATE of bug 103322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2017-06-12 15:13 UTC by Telesto
Modified: 2019-01-10 21:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (10.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-12 15:16 UTC, Telesto
Details
Screencast (761.50 KB, video/x-msvideo)
2017-06-22 13:13 UTC, Telesto
Details
Screencast (926.00 KB, video/x-msvideo)
2017-06-24 08:33 UTC, Telesto
Details
Bibisect log (2.75 KB, text/plain)
2018-03-24 15:30 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-12 15:13:05 UTC
Description:
The text is re-positioning when scrolling up an down if the Automatic Spell Checking is enabled


Steps to Reproduce:
1. Open the attached file
2. Enable the Automatic Spell Checking (SHIFT+F7)
3. Scroll a tick down (hiding the three rows)
4. Scroll up again
5. Text is moving a bit

Actual Results:  
The text is re-positioning when scrolling up an down

Expected Results:
Text should stay put


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.5.0.0.alpha0+
Build ID: 076ed447f694239d5c67adee528ea6e471d909ff
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-09_23:54:20
Locale: nl-NL (nl_NL); Calc: CL

and in
5.4b1

but not in
Versie: 5.3.3.1 
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: GL; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-12 15:16:43 UTC
Created attachment 133975 [details]
Example file
Comment 2 Buovjaga 2017-06-22 13:00:38 UTC
I installed this for the dev version as it is not bundled: https://extensions.libreoffice.org/extensions/english-dictionaries

I cannot reproduce the problem.

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 2404a17e157273430d40ceaa1ab1275e7b50ba6e
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-16_23:41:27
Locale: fi-FI (fi_FI); Calc: group
Comment 3 Telesto 2017-06-22 13:13:36 UTC
Created attachment 134207 [details]
Screencast

Version: 6.0.0.0.alpha0+
Build ID: 18f513145477d4621290253d936dad7a40ee4c05
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-21_06:40:38
Locale: nl-NL (nl_NL); Calc: CL
Comment 4 Telesto 2017-06-22 15:09:58 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2017-06-22 15:18:50 UTC
(In reply to Telesto from comment #4)
> Every time scrolling down and up again it notice this:
> Z:\LibreOfficeDev 6\program\OpenOffice\dict_word_prepostdash.brk -> Path not
> found

Ok.. just to check, can you reproduce it in safe mode?
Comment 6 Telesto 2017-06-22 16:20:05 UTC
> Ok.. just to check, can you reproduce it in safe mode?
Yes, I can reproduce it in save-mode (I checked; with LibO6.0.0.0)
Comment 7 Eike Rathke 2017-06-23 16:49:51 UTC
Seeing ICU 59 in that list, please try with 5.4.0.beta2 where internal ICU for Windows was wound back to 58.
Comment 8 Eike Rathke 2017-06-23 16:52:13 UTC
And why was this set to Hardware All/All  if so far only x86 Windows was affected.
Comment 9 Telesto 2017-06-24 08:33:00 UTC
Created attachment 134238 [details]
Screencast

(In reply to Eike Rathke from comment #7)
> Seeing ICU 59 in that list, please try with 5.4.0.beta2 where internal ICU
> for Windows was wound back to 58.

5.4.0b2 isn't reading dict_word_prepostdash.brk. However the text gets realigned when scrolling up after 'hiding' the text by scrolling down. (screencast with 5.4.0. added)

And why was this set to Hardware All/All  if so far only x86 Windows was affected.
-> Bad habit. It's the default setting
Comment 10 Telesto 2018-03-24 15:30:10 UTC
Created attachment 140860 [details]
Bibisect log

Bisected to:

author	Khaled Hosny <khaledhosny@eglug.org>	2017-02-12 11:08:59 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-03-14 14:50:12 +0000
commit	ded07624096183ed310187f29d4692bb39b7d24a (patch)
tree	97cd5a53d45253defc9b3e45716b85014253c281
parent	d3b9b4e41e31ce276d2d7354602a586b300adee9 (diff)
tdf#105454: Stop ignoring font kerning setting
Make sure the default is for kerning to be enable, and honor the setting
to disable it.

This also updates the expectations for chart2_xshape tests for file that
had kerning disabled and was previously ignored.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ded07624096183ed310187f29d4692bb39b7d24a
Comment 11 Khaled Hosny 2018-03-24 16:20:20 UTC
(In reply to Telesto from comment #10)
> Created attachment 140860 [details]
> Bibisect log
> 
> Bisected to:
> 
> author	Khaled Hosny <khaledhosny@eglug.org>	2017-02-12 11:08:59 +0200
> committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-03-14 14:50:12 +0000
> commit	ded07624096183ed310187f29d4692bb39b7d24a (patch)
> tree	97cd5a53d45253defc9b3e45716b85014253c281
> parent	d3b9b4e41e31ce276d2d7354602a586b300adee9 (diff)
> tdf#105454: Stop ignoring font kerning setting
> Make sure the default is for kerning to be enable, and honor the setting
> to disable it.
> 
> This also updates the expectations for chart2_xshape tests for file that
> had kerning disabled and was previously ignored.
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=ded07624096183ed310187f29d4692bb39b7d24a

All that commit does is disable kerning when asked to do so, which is supposedly was the intended behavior at some point in time before we started using HarfBuzz on Linux and then everywhere. If some higher level component is enabling/disabling things incorrectly, then there is nothing we can do at VCL level.
Comment 12 subha 2018-03-30 11:44:45 UTC
>Steps to Reproduce:
>1. Open the attached file
>2. Enable the Automatic Spell Checking (SHIFT+F7)
>3. Scroll a tick down (hiding the three rows)
>4. Scroll up again
>5. Text is moving a bit

>Actual Results:  
>The text is re-positioning when scrolling up an down

>Expected Results:
>Text should stay put

Not able to reproduce this Bug...
Working Fine...in Libre Office 6.0.2(Windows 7 32 bit)
Comment 13 Telesto 2018-03-30 12:51:24 UTC
(In reply to subha from comment #12)
> Not able to reproduce this Bug...
> Working Fine...in Libre Office 6.0.2(Windows 7 32 bit)

Still reproducible for me with Windows 8.1 VM & a 'normal' system
Version: 6.1.0.0.alpha0+
Build ID: 546ed01e62c9a36a675c7390371aaec7f1647a33
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-26_15:39:48
Locale: nl-NL (nl_NL); Calc: CL
Comment 14 Xisco Faulí 2018-11-27 20:05:04 UTC
Hi Telesto,
Is this issue still reproducible in master ?
Comment 15 Telesto 2019-01-10 21:22:02 UTC

*** This bug has been marked as a duplicate of bug 103322 ***