Bug 108499 - "Secondary selection" clipboard is not functioning
Summary: "Secondary selection" clipboard is not functioning
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2017-06-13 06:15 UTC by Todd
Modified: 2019-09-03 00:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2017-06-13 06:15:48 UTC
Dear Libre Office Developers,

This bug concerns Linux.

X11 has four clipboards.  Secondary and Primary are the most used.  Here is a video showing each:

http://www.cs.man.ac.uk/~chl/Secondary-Selection.mp4

The "Secondary Selection" clipboard is not functioning in Libre Office.  This is a productivity killer.

To reproduce, open a Writer with a lot of text in it, hold down the <ctrl> key and leave it down, highlight some text not next to the cursor, move to the mouse to another section not near the cursor, center mouse click to drop the highlighted text (<ctrl> still pressed), release the <ctrl> key.  The highlighted text should copy to the new mouse location and the cursor should remain where it was originally.  The video shows this is great detail.

And, since this works in Leaf Pad and Leaf Pad is Open Source, it should be pretty easy to figure out how to fix Libre Office.

Many thanks,
Comment 1 Buovjaga 2017-06-22 15:39:03 UTC
It's true, I tried in Kate editor and it truly is pasting where my mouse is hovering.
LibreOffice does not do this.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: d36dc7b3ce28e6fe1590aa7cb72e53e2d745c073
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 22nd 2017

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 almos 2017-08-22 21:48:17 UTC
The selection clipboard used to be working, this is new in 5.4.
Comment 3 Buovjaga 2017-08-23 04:24:05 UTC
(In reply to almos from comment #2)
> The selection clipboard used to be working, this is new in 5.4.

Todd reported this against 5.3.3, so it can't be new in 5.4
Comment 4 QA Administrators 2018-08-24 02:43:45 UTC Comment hidden (obsolete)
Comment 5 Todd 2018-08-24 21:25:29 UTC
Still not working in LibreOffice-6.1.0-Linux_x86-64_rpm.tar.gz
Comment 6 QA Administrators 2019-09-02 09:26:12 UTC Comment hidden (obsolete)
Comment 7 Todd 2019-09-03 00:39:26 UTC
Fedora 30, x64
LibreOffice-6.3.0-Linux_x86-64_rpm.tar.gz

Still not working in LO Writer

Still work in Leafpad