Bug 108522 - Restore (or configure) old behavior when clicking on an input field
Summary: Restore (or configure) old behavior when clicking on an input field
Status: RESOLVED DUPLICATE of bug 79877
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.3.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-14 12:59 UTC by Bernhard
Modified: 2017-06-22 17:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard 2017-06-14 12:59:07 UTC
Description:
Since LibreOffice 4.2, input fields can be edited in-place. This means, clicking of an input field no longer opens the 'edit field' dialog, but selects the field. Typing text will then change the field content without needing a dialog.




Steps to Reproduce:
1.Open new Writer document
2. Enter a new input field. Click Insert, then enter a value for the field. Click OK.
3. Left-Click on the input field.

Actual Results:  
The field content is selected.
a) Typing some text will replace the selection.
b) Inserting another input field will replace the current input field with the new one.

Expected Results:
Clicking on an input field should trigger the "edit field" dialog.



Reproducible: Always

User Profile Reset: No

Additional Info:
This change was intentional via "#i33737# enable in-place editing of Input Fields" (branch aoo/trunk). Before that change (4.1.6 -> 4.2), clicking on an input field triggered the "edit field" dialog where a new value could be entered.

Should the behavior at least be configurable (for someone who wants to keep the old behavior)?



User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36
Comment 1 Buovjaga 2017-06-18 10:55:22 UTC
So why is double-clicking not enough for you?
Comment 2 Martin Nathansen 2017-06-22 14:18:05 UTC
I can confirm this bug with LO 4.3.3.2 on debian jessie.
It is a regression regarding usability and therefore should be fixed.
Comment 3 Buovjaga 2017-06-22 14:51:24 UTC
You have failed to explain why it is a regression against usability and why double-clicking is not enough. Engaging UX team.
Comment 4 Michael Stahl (CIB) 2017-06-22 14:56:29 UTC
that's not a bug, that's a feature.

users have complained about the ridiculous old input field for years.

you can get the input field dialog by double-clicking on it,
or by right clicking and selecting "Fields..." from the context menu.
Comment 5 Martin Nathansen 2017-06-22 15:50:40 UTC
So just 38min after I confirmed this bug and you closed it as NOTABUG and stopped further discussions about it forever.

Why that?
Comment 6 Katarina Behrens (CIB) 2017-06-22 16:34:09 UTC
> that's not a bug, that's a feature.
> 
> users have complained about the ridiculous old input field for years.

So now some users complain because they are used to the ridiculous old input field and the new behaviour is change for the worse for them [1] You can't make everyone happy.

So how about restoring the old behaviour and hiding it behind some, dunno, 'EnableLegacyFieldEditing' expert config option?


[1] maybe they are simply reluctant to learn new things
Comment 7 V Stuart Foote 2017-06-22 17:10:08 UTC
The in-place field editing [1] is functional.

The double click, or context menu, to open "Edit Fields" dialog is correct and consistent behavior and has been present since 4.2 as noted, picked up from AOO work [2]. 

Unfortunately it probably is not the correct dialog as the Edit Fields dialog does not actually allow editing of the field content [3]. 

We have bug 79877 (and better discussion in dupe bug 75319) to rather than the "Edit Fields" dialog use the Field input dialog for proforma entry--as used to be connected to the .uno:UpdateInputFields and assigned the F9_SHIFT_F1 short cut, but that remains non functional for sequential editing of templated forms. 

Setting this as duplicate of tdf#79877

=-ref-=

[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=c2b5521921b806ff7b04cdacebde3834d2aafd4b


[2] https://bz.apache.org/ooo/show_bug.cgi?id=33737

[3] https://bz.apache.org/ooo/show_bug.cgi?id=125108

*** This bug has been marked as a duplicate of bug 79877 ***