Download it now!
Bug 108584 - user\config\autotbl.fmt is read more than a 1000 times every time when cutting some text in Writer (see comment 4)
Summary: user\config\autotbl.fmt is read more than a 1000 times every time when cuttin...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Too-Much-File-Access
  Show dependency treegraph
 
Reported: 2017-06-17 12:46 UTC by Telesto
Modified: 2018-01-15 19:09 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
BT (6.58 KB, text/rtf)
2017-09-08 08:08 UTC, Telesto
Details
BT & Few screenshots (734.50 KB, application/x-zip-compressed)
2017-09-18 21:15 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-17 12:46:23 UTC
Description:
Disk-read activity has doubled to 80mb/s by recurring opening, read of user\config\autotbl.fmt

Pretty similar to bug 104582

Steps to Reproduce:
Steps to Reproduce:
1. Open attachment 132550 [details] (bug 107021)
2. From form letter, goto "Tools" > "Mail Merge Wizard..."
3. Hit "Next>>" twice to get to data selection 
4. "Select Address List..." and select ODS spreadsheet containing 2000 row recipient list
5. Uncheck address block option
6. Hit "Next>>"
7. Uncheck salutation option
8. Hit "Finish"
9. In the tool bar that appears under the formatting tool bar, select "Save Merged Documents"
10. Select "Save As Individual Documents"
11. Click "Save Documents"

Monitor disk activity with ProcessMonitor and/or Process Explorer

Actual Results:  
Recurring opening and read of user\config\autotbl.fmt

Expected Results:
Shouldn't happen


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: cbf371e07fd5dea1ea08a1f299360d1273961ebd
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-14_23:13:57
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa-GL
Locale: en-US (nl_NL)


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-17 12:51:20 UTC
Found in
Versie: 5.4.0.0.beta2 
Build ID: 3cc1cdd8ee50f144e5514da51800a08119754d8f
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.3.0.0.beta1  (x64)
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; Versie besturingssysteem:Windows 6.19; UI Render: standaard; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Telesto 2017-06-23 09:22:35 UTC
Similar behavior - reading of user\config\autotbl.fmt - exists when opening a Writer Document from start center. However not in the same extend, but seems related.
Comment 3 Buovjaga 2017-06-25 06:48:27 UTC
Repro with Process monitor. It is weird, because autotbl.fmt is table styles (the old) and there is no table in the document.

Version: 6.0.0.0.alpha0+ (x64)
Build ID: 2404a17e157273430d40ceaa1ab1275e7b50ba6e
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-16_23:41:27
Locale: fi-FI (fi_FI); Calc: group
Comment 4 Telesto 2017-07-16 20:09:39 UTC
This is also happening every time when cutting some random text in a Writer document

@Baron
Would you mind to take a look a this one?

Found in
Versie: 5.4.0.2 
Build ID: 2b906d450a44f2bbe506dcd22c51b3fa11dc65fd
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

but not in:
Versie: 5.3.3.1 
Build ID: 46360c72c4823cefeaa85af537fba22bd568da7e
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; Layout-Engine: nieuw; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Telesto 2017-09-08 08:08:07 UTC
Created attachment 136110 [details]
BT

I get the following trace from Instruments when following the steps from comment 4
Comment 6 Telesto 2017-09-18 21:15:32 UTC
Created attachment 136351 [details]
BT & Few screenshots
Comment 7 Telesto 2017-09-18 21:18:49 UTC
@Julien
Any clue why this is happening (Instruments BT & screenshots attached)?
Comment 8 Telesto 2017-09-28 11:27:12 UTC
Bibisect based on comment 4

/bibisect-win32-5.3
$ git bisect bad
bc7327a47ca02d26a0f501d9d739fa33272192d9 is the first bad commit
commit bc7327a47ca02d26a0f501d9d739fa33272192d9
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Jul 27 10:34:29 2016 -0700

    source sha:b7138e03ebc8a33258c099c5cf6015970646a40e

    source sha:b7138e03ebc8a33258c099c5cf6015970646a40e

:040000 040000 3c88e6a3d95336063758b2901bc01bddff6fa8ef eeca12ae25320b7cdb638c898fb324f99dd6b1fc M      instdir

~/bibisect-win32-5.3
$ git bisect log
# bad: [a374222bc87bd9e75ea2f1ca45d189932a1967f8] source sha:aa09fd58bd499a2a2c3a32c5f613892bad54076c
# good: [defb73f1c6e2a66dbd21ba89e684f57427e8bc4b] source sha:5b168b3fa568e48e795234dc5fa454bf24c9805e
git bisect start 'origin/master' 'oldest'
# bad: [0b4408f0568ad1da0797543c0ee2955c386267ee] source sha:8f7886c742cae5e012e52029c20925aa7b0fb6ea
git bisect bad 0b4408f0568ad1da0797543c0ee2955c386267ee
# good: [16b554fa5f3a3d2723e78d894d644ac9303a7991] source sha:50a6f3d51f32e7176c3b2d036c60bb48d51d6a1a
git bisect good 16b554fa5f3a3d2723e78d894d644ac9303a7991
# bad: [1d5414e6dc71de667a2e7457f4a169c3575a4a70] source sha:f16c803e7f5186632adeffc2dad579cf2c720b15
git bisect bad 1d5414e6dc71de667a2e7457f4a169c3575a4a70
# bad: [5942c07976de306d75affaeadcde1f3697bc4fd3] source sha:4fc3c8a3df485f6dccdcb2c51c6266fbd0dace3e
git bisect bad 5942c07976de306d75affaeadcde1f3697bc4fd3
# good: [88223d9fd206d9710ad6c3bde7ad927e19f333cd] source sha:aaa5a098f4a3644a6f78cafa1c86f1db12c4f6ed
git bisect good 88223d9fd206d9710ad6c3bde7ad927e19f333cd
# good: [8ad562dc944508ee3d7ba85cf1ab72cf91c2a622] source sha:69dbf6f08604f6a97390fb7ab06dfe86c1cf05a0
git bisect good 8ad562dc944508ee3d7ba85cf1ab72cf91c2a622
# good: [b2c5f6452f81cc59a7ba2275e1b8d9104514fd50] source sha:bae0d30e1983d371875477775ac83d993e6bd129
git bisect good b2c5f6452f81cc59a7ba2275e1b8d9104514fd50
# bad: [0f4dff2f3d421cb29fc3afb2a85c93b597ee20a9] source sha:8bb1726007f641dff2aa17d2e79a089e09fd9770
git bisect bad 0f4dff2f3d421cb29fc3afb2a85c93b597ee20a9
# good: [0e0df2d09a82bcf3ec921e2376cdf9fbc6f8c62a] source sha:187044b5e837c24223ca4625df48d0161a72945f
git bisect good 0e0df2d09a82bcf3ec921e2376cdf9fbc6f8c62a
# good: [25503583a9743cc95d8a7997c3b4ddf0e24ed7ef] source sha:d78012872a15cdd0347cbabfc13e03ce5511bf90
git bisect good 25503583a9743cc95d8a7997c3b4ddf0e24ed7ef
# good: [a69b7f07de62d062b66646706322bf0fe27aeaee] source sha:7c84a219e3cc8d623826343f547ba8adacca6d56
git bisect good a69b7f07de62d062b66646706322bf0fe27aeaee
# good: [c5f02f3d0c35244e59f5b131696f384735a7ddba] source sha:9e63e60d6f00ee690fafb9f21f2cafb08a6ad92e
git bisect good c5f02f3d0c35244e59f5b131696f384735a7ddba
# bad: [bc7327a47ca02d26a0f501d9d739fa33272192d9] source sha:b7138e03ebc8a33258c099c5cf6015970646a40e
git bisect bad bc7327a47ca02d26a0f501d9d739fa33272192d9
# first bad commit: [bc7327a47ca02d26a0f501d9d739fa33272192d9] source sha:b7138e03ebc8a33258c099c5cf6015970646a40e
Comment 9 Telesto 2017-10-04 19:12:04 UTC
author	Jakub Trzebiatowski <ubap.dev@gmail.com>	2016-07-26 12:29:40 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-07-27 12:13:18 (GMT)
commit	b7138e03ebc8a33258c099c5cf6015970646a40e (patch)
tree	6c4a872182c08e96c832e8b1f60b0cfbfdbb162e
parent	9e63e60d6f00ee690fafb9f21f2cafb08a6ad92e (diff)

GSoC Writer Table Styles; Import bugfix
+ Binary autoformats are loaded into document on document creation
+ Imported table styles overwrite existing styles.
Comment 10 Telesto 2017-10-04 19:12:40 UTC
Adding Cc to Jakub Trzebiatowski
Comment 11 Telesto 2018-01-15 19:09:05 UTC
No repro with 
Version: 6.1.0.0.alpha0+
Build ID: 80fb8d406ced47e6a2089f0c8ba5c103d2fec91f
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-01-15_05:18:42
Locale: nl-NL (nl_NL); Calc: CL

Based on comment 4