Bug 108605 - Memory leaking when using the pattern area fill
Summary: Memory leaking when using the pattern area fill
Status: RESOLVED DUPLICATE of bug 111894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2017-06-18 08:00 UTC by Telesto
Modified: 2017-09-12 18:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-18 08:00:14 UTC
Description:
Memory leaking when using the pattern area fill

Steps to Reproduce:
1. Monitor memory usage of soffice.bin with for example Process Explorer
2. Open Draw
3. Go to format -> Page properties. Paper format A2; Orientation landscape
4. Add a large (page filling) shape (Smiley)
5. With shape selected go to sidebar -> Properties deck -> Area. Select Pattern fill. Memory usage will increase with 50 MB.
6. Delete the shape. And repeat step 4 & 5

Compare with LibO4.3.7.2
2. Open Draw
3. Go to format -> Page properties. Paper format A2; Orientation landscape
4. Add a large (page filling) shape (Smiley)
5. Right click the shape. Selet Area in context menu. 
6. Bitmap Tab -> and create you're own pattern with the pattern editor. Apply.



Actual Results:  
Memory usage keeps increasing with 50 MB

Expected Results:
No or less leaking


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: cbf371e07fd5dea1ea08a1f299360d1273961ebd
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-14_23:13:57
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

but nearly no leakage in
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Buovjaga 2017-06-25 06:49:47 UTC
Repro. I asked on -dev to confirm, if this should be investigated and the opinion was "yes" (I thought it might just be related to undo).

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: 5ff95b16cf9fb2ac7b2b970614e3b98f55978dc0
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 23rd 2017
Comment 2 Buovjaga 2017-06-27 14:27:25 UTC
Mem stops increasing, if I set the undo steps to a small value in Tools - Options - LibO - Advanced - Expert config: org.openoffice.Office.Common/Undo
Comment 3 raal 2017-07-17 18:16:13 UTC
(In reply to Buovjaga from comment #2)
> Mem stops increasing, if I set the undo steps to a small value in Tools -
> Options - LibO - Advanced - Expert config: org.openoffice.Office.Common/Undo

I can confirm. So we can close the bug?
Comment 4 Buovjaga 2017-07-17 18:20:34 UTC
raal: what about this:

(In reply to Telesto from comment #0)
> but nearly no leakage in
> Version: 4.3.7.2
> Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
Comment 5 Telesto 2017-09-12 18:17:31 UTC
No repro with
Version: 6.0.0.0.alpha0+
Build ID: 75ca51725274b95417aa2c7f169145e3cd3b3b4f
CPU threads: 4; OS: Windows 6.29; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-09-12_03:59:49
Locale: nl-NL (nl_NL); Calc: CL

*** This bug has been marked as a duplicate of bug 111894 ***