Bug Hunting Session
Bug 108610 - Crash: Crash when switching slide while an image is selected
Summary: Crash: Crash when switching slide while an image is selected
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.0.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 108590 108633 108685 108695 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-18 09:51 UTC by Telesto
Modified: 2017-06-22 16:13 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace (17.05 KB, text/plain)
2017-06-21 08:20 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-18 09:51:41 UTC
Description:
Crash when switching slide while an image is selected

Steps to Reproduce:
1. Open attachment 123313 [details]
2. Select the image with glasses on the first slide
3. Select slide 2 in the sidebar

Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: cbf371e07fd5dea1ea08a1f299360d1273961ebd
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-14_23:13:57
Locale: nl-NL (nl_NL); Calc: CL

but not in
Version: 5.4.0.0.beta2
Build ID: 3cc1cdd8ee50f144e5514da51800a08119754d8f
CPU threads: 4; OS: Windows 6.2; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2017-06-18 10:11:31 UTC
Confirmed in

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Julien Nabet 2017-06-18 20:06:28 UTC
On pc Debian x86-64 with master sources updated some days ago, I could reproduce this (gen rendering).
I got this bt:
#0  0x0000000000000031 in ?? ()
#1  0x00007fffef7e74e0 in sdr::event::TimerEventHandler::Invoke (this=0x55555bc8dd10) at /home/julien/lo/libreoffice/svx/source/sdr/event/eventhandler.cxx:113
#2  0x00007fffec8ae81b in ImplSchedulerData::Invoke (this=0x55555ba75320) at /home/julien/lo/libreoffice/vcl/source/app/scheduler.cxx:46
#3  0x00007fffec8aec7b in Scheduler::ProcessTaskScheduling (bIdle=true) at /home/julien/lo/libreoffice/vcl/source/app/scheduler.cxx:159

The weird thing is I got a crash just opening and selecting the image (so without changing slide) with gtk3 rendering.
Comment 3 Xisco Faulí 2017-06-21 08:20:02 UTC
Created attachment 134179 [details]
gdb backtrace
Comment 4 Julien Nabet 2017-06-21 08:35:05 UTC
Caolán: thought you might be interested in this one since there's an extra pb with gtk3 rendering.

(let's increase importance since it's a crash+regression)
Comment 5 Caolán McNamara 2017-06-21 12:07:55 UTC
regression from

commit e4e4d5713e248f02faf7aa6199b11e152973de8e
Author: Noel Grandin <noel.grandin@collabora.co.uk>
Date:   Wed May 31 15:40:25 2017 +0200

    clang-tidy readability-delete-null-pointer
    
    which in turn triggered some loplugin:useuniqueptr

only partially fixed by

commit 93a288bd75d7caed46d6f29bf006f3d97a9602a9
Author: Michael Stahl <mstahl@redhat.com>
Date:   Mon Jun 12 21:44:57 2017 +0200

    svx: fix the std::unique_ptr that deletes itself twice
Comment 6 Xisco Faulí 2017-06-21 12:13:13 UTC
*** Bug 108633 has been marked as a duplicate of this bug. ***
Comment 7 Caolán McNamara 2017-06-21 12:15:45 UTC
https://gerrit.libreoffice.org/#/c/39052/
Comment 8 Xisco Faulí 2017-06-21 12:41:35 UTC
*** Bug 108590 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2017-06-21 20:30:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa58890324bf15560c66fcb58a19c169da228c2e

Resolves: tdf#108610 crash on double delete of async event

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2017-06-21 21:30:40 UTC
*** Bug 108685 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2017-06-22 16:13:56 UTC
*** Bug 108695 has been marked as a duplicate of this bug. ***