Download it now!
Bug 108611 - EDITING: Hovering through different font with preview enabled is slowish and CPU hogging
Summary: EDITING: Hovering through different font with preview enabled is slowish and ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, perf, regression
Depends on:
Blocks: Too-Much-File-Access Font-Preview
  Show dependency treegraph
 
Reported: 2017-06-18 10:38 UTC by Telesto
Modified: 2017-10-06 14:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (18.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-06-18 10:39 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-06-18 10:38:46 UTC
Description:
Hovering through different font with preview enabled is slowish and CPU hogging



Steps to Reproduce:
1. Open attached file
2. Select A1 A234
3. Hoover through the different font with font preview enabled
4. Monitor CPU consumption and snappiness

Actual Results:  
In 5.2.4.2 it feels snappy and fast (CPU usage around 10%)
With 6.0.0.0 preview is lagging a bit and CPU usage is around 20%)

Expected Results:
Behavior like 5.2.4.2


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 6.0.0.0.alpha0+
Build ID: cbf371e07fd5dea1ea08a1f299360d1273961ebd
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-14_23:13:57
Locale: nl-NL (nl_NL); Calc: CL

but not in
Versie: 5.2.4.2 
Build ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

It's keeps trying a non available file:
Z:\LibreOfficeDev 6\program\OpenOffice\char_en.brk	
Z:\LibreOfficeDev 6\program\OpenOffice\char.brk	


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2017-06-18 10:39:27 UTC
Created attachment 134101 [details]
Example file
Comment 2 Buovjaga 2017-06-27 11:38:58 UTC
Yep, confirm the approximate CPU %

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: f808c50c6eece87d515df3b84b1c774395b5d9bc
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 26th 2017

(In reply to Telesto from comment #0)
> It's keeps trying a non available file:
> Z:\LibreOfficeDev 6\program\OpenOffice\char_en.brk	
> Z:\LibreOfficeDev 6\program\OpenOffice\char.brk	

Looks like this is the code path: http://opengrok.libreoffice.org/xref/core/i18npool/source/breakiterator/breakiterator_unicode.cxx#125
Comment 3 Telesto 2017-10-06 14:08:23 UTC
Fixed:
Version: 6.0.0.0.alpha0+
Build ID: b087e451527f2e497ccab83b63b4f10099bfb8b8
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-03_23:43:39
Locale: nl-NL (nl_NL); Calc: CL