Download it now!
Bug 108641 - Bibliography does not pick up added entries from the database
Summary: Bibliography does not pick up added entries from the database
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-19 22:41 UTC by Ben
Modified: 2018-12-03 13:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibliography entries do not get picked up from database (59.47 KB, image/png)
2017-06-19 22:43 UTC, Ben
Details
Bibliography database (79.06 KB, image/png)
2017-06-19 22:52 UTC, Ben
Details
Bibliography Edit Index (31.09 KB, image/png)
2017-06-19 22:56 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2017-06-19 22:41:21 UTC
After:
- Creating entities in the Bibliography data base
- Creating a bibliography
- Creating Bibliography entries in the document
- Running Update index, the Bibliography does not pick up entries from the database. I have the impression that the first time I ran the Update index it was ok but after adding new entries to the database it generated partial results. See attachments.
Comment 1 Ben 2017-06-19 22:43:50 UTC
Created attachment 134144 [details]
Bibliography entries do not get picked up from database

See highlights in screenshot
Comment 2 Ben 2017-06-19 22:52:52 UTC
Created attachment 134145 [details]
Bibliography database
Comment 3 Ben 2017-06-19 22:56:05 UTC
Created attachment 134146 [details]
Bibliography Edit Index

Year is specified but does not appear in Bibliography
Comment 4 Ben 2017-06-19 23:01:56 UTC
This is an issue since OpenOffice. I hope this gets resolved soon because I'm running against a publication deadline.
Comment 5 Julien Nabet 2017-06-21 18:42:10 UTC
Just for information, you can take a look here:
http://opengrok.libreoffice.org/xref/core/extras/source/database/biblio.README#18
Comment 6 Ben 2017-06-21 21:12:42 UTC
Julien,

Thank you for the link. It provides partial clarification. I have a few questions to get a full understanding of the underlying mechanics.

It says: "If you edit biblio.odb in "base" you will really just be changing your local
data store."

What is meant by 'local store'?

I've have mostly used "tools->bibliography database and edit your local one through that UI". In the past I also used "base" when I ran into Bibliography update issues and thought there was a bug.

What is the full path for extras/source/database/ and extras/source/database/biblio.odb?

Why is copying needed in a completely different directory?

It seems to me that there is a lot of complexity here. Is this documented in any of the User Guides. Is there an effort planned to reduce this complexity?
Regular users like me will not be able to figure this out.
Comment 7 Julien Nabet 2017-06-22 07:12:51 UTC
I can't tell much about this except:
dbf format means dBASE database type. dbf format is the main file of dBASE, dbt format is a kind of extension file to store some MEMO information.

bibliography.odb is just wrapper for biblio.dbf, it's the bibliography for LibreOffice (some time ago OpenOffice), so just an example file.

Have in mind that dbf management is a buggy, some information may be lost when dealing with dbt file.

In brief, I think (I might be wrong) that if you don't know a bit of dBASE, you should keep away from bibliography part.

What's your goal? To add entries of official bibliography of LO or to have a bibliography about something else for you?

If you want a file containing all your data, the best thing to would be to create a brand new odb file HSQLDB or Firebird (you need to enable experimental to access this format).

Caolán: I put you in cc just in case you'd have more information. (I noticed you had created the README file quoted in comment 5).If it's not the case, don't hesitate to uncc yourself of course.
Comment 8 Caolán McNamara 2017-06-22 08:11:26 UTC
My notes in that README are directed towards developers who want to add extra entries to the same database. But I guess the general point holds that if you want to edit the bibliography use tools->bibliography
Comment 9 Ben 2017-06-22 22:41:07 UTC
Julien,

I'm merely trying to create a Bibliography at the end of a book which I'm trying to complete.

To give you a better sense of the history:
1. I started out with a set of references of which I put the information in the database by using tools->bibliography.
2. Added references in the document to entries in the database.
3. Generated the Bibliography in the document. All might have been ok at this point (not entirely sure).
4. Added new elements in the database using tools->bibliography.
5. Generated the Bibliography in the document again. I think it was at this point where information was not included in the document, although it appear in the database view of tools->bibliography.

I may have used the database directly at a much after that when I noticed that the Bibliography did not get fully updated when using tools->bibliography.

I don't know how to get out of this state since I the explanation under the link you provided was not entirely clear to me.

Any suggestions would be welcome to get out of this state so that I can finish my work.

BTW, I recall that I reported this issue several years ago and other people had similar issues. I don't know it the issue got lost with the transition form OO to LO or it was deemed to be resolved.
Comment 10 Ben 2017-07-05 23:40:35 UTC
I know this has been a long-standing issue because I encountered this already many years ago. Yhe following may be relevant as well:

https://bz.apache.org/ooo/show_bug.cgi?id=44189
Comment 11 Buovjaga 2017-08-15 09:18:52 UTC
(In reply to Ben from comment #10)
> I know this has been a long-standing issue because I encountered this
> already many years ago. Yhe following may be relevant as well:
> 
> https://bz.apache.org/ooo/show_bug.cgi?id=44189

So did you try the software in this: http://www.dusystems.com/oobf.html
Comment 12 Xisco Faulí 2017-10-31 15:47:33 UTC
(In reply to Buovjaga from comment #11)
> (In reply to Ben from comment #10)
> > I know this has been a long-standing issue because I encountered this
> > already many years ago. Yhe following may be relevant as well:
> > 
> > https://bz.apache.org/ooo/show_bug.cgi?id=44189
> 
> So did you try the software in this: http://www.dusystems.com/oobf.html

Hello Ben,
Could you please answer the question above?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the question is answered
Comment 13 Ben 2017-10-31 20:26:57 UTC
Xisco,

I have -not- tried  http://www.dusystems.com/oobf.html
Comment 14 Buovjaga 2017-11-01 10:06:37 UTC
(In reply to Ben from comment #13)
> Xisco,
> 
> I have -not- tried  http://www.dusystems.com/oobf.html

Ok, please report here after trying it.
Comment 15 QA Administrators 2018-05-02 15:46:38 UTC Comment hidden (obsolete)
Comment 16 Ben 2018-05-02 17:15:27 UTC
I have not tried http://www.dusystems.com/oobf.html because of the need to have a stable solution going forward.

I have tested the database option many times over various releases but not anymore recently due to lack of time.

At this time, I have entered the Bibliography information in the document itself instead of the database. Hopefully this provides better stability.
Comment 17 QA Administrators 2018-11-05 16:07:55 UTC Comment hidden (obsolete)
Comment 18 QA Administrators 2018-12-03 13:20:04 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20181203