Bug Hunting Session
Bug 108661 - Removing direct formatting doesn't remove background
Summary: Removing direct formatting doesn't remove background
Status: RESOLVED DUPLICATE of bug 99573
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError, regression
Depends on:
Blocks: Clear-Formatting Paragraph
  Show dependency treegraph
 
Reported: 2017-06-20 21:53 UTC by Gabriele Ponzo
Modified: 2017-07-30 21:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Ponzo 2017-06-20 21:53:28 UTC
Description:
Using "Remove Direct Formatting" (CTRL+M) it should remove any property specified on a paragraph, bringing it back to its parent style.

But from 4.4 on, when you call that feature, all properties are reset, except for any background you've set, such as color, gradient, bitmap and so on, that remains there.

Steps to Reproduce:
1. Open Writer
2. Set a background color (i.e. from Menu Format -> Paragraph --> Area)
3. hit CTRL+M (or click on "Remove Direct Formatting" button on Format ToolBar

Actual Results:  
The background stays there, other properties (i.e. bold, justified...) are correctly reset

Expected Results:
The paragraph's attributes should be all reset, including background, bringing that paragraph back to its parent style attributes.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/58.0.3029.110 Chrome/58.0.3029.110 Safari/537.36
Comment 1 Yousuf Philips (jay) (retired) 2017-06-20 22:03:14 UTC
In 3.3 to 4.3, it used to be the 'Background' tab with options only to change the color and image and 4.4 it was changed to an 'Area' tab which has color, gradient, image, and hatch.
Comment 2 Andreas Säger 2017-07-22 08:42:53 UTC
After saving and reloading LO applies the correct para back color. Could be a screen updating problem.
Comment 3 Yousuf Philips (jay) (retired) 2017-07-30 21:00:49 UTC
Not sure why you filed this bug Gabriele when you confirmed bug 99573 twenty days before filing this bug.

*** This bug has been marked as a duplicate of bug 99573 ***
Comment 4 Gabriele Ponzo 2017-07-30 21:14:02 UTC
I'm sorry, I guess it's just because I forgot to note the other bug number on my (long) bug list.

I was teaching QA to newcomers and talking I just didn't take the note.

Sorry, I really apologize :(