Bug 108765 - MSOffice's default footnote style (superscript) desired when using MS formats (comment 10).
Summary: MSOffice's default footnote style (superscript) desired when using MS formats...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Styles-Defaults DOCX-Footnote-Endnote
  Show dependency treegraph
 
Reported: 2017-06-25 13:28 UTC by Yousuf Philips (jay)
Modified: 2017-10-13 11:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
MSO vs LO (73.67 KB, image/png)
2017-09-05 09:35 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2017-06-25 13:28:23 UTC
Steps:
1. Open attachment 131189 [details] in Writer
2. Insert a footnote and notice that
   a. footnote text is set to 12pt as Footnote paragraph style is empty
   b. footnote number isnt superscript in Footnote Characters character style
   c. there is no space between footnote number and text
3. Open attachment 131189 [details] in Word
4. Insert a footnote and notice that
   a. footnote text is set to 10pt in Footnote Text paragraph style
   b. footnote number is superscript in Footnote Reference character style
   c. there is a space (U+20) between the footnote number and text

The issue is that 'footnote text' paragraph style and 'footnote reference' character styles arent defined in styles.xml.

Version: 6.0.0.0.alpha0+
Build ID: 1f4d7fc8618828222d7f4447daed4c3361edeea6
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Buovjaga 2017-06-28 17:23:14 UTC
Repro with document.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha0+
Build ID: f808c50c6eece87d515df3b84b1c774395b5d9bc
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 26th 2017
Comment 2 Justin L 2017-08-24 23:40:26 UTC
see bug 53175's fix from Cédric Bosdonnat 2012-08-20 09:29:29 (GMT)
commit b95d203bc17c83ec0fe5139f519d53ed1d842d3a (patch)
fdo#53175: Don't load the default values of the styles in writerfilter
...or we may have some additional properties set on some styles.
Comment 3 Justin L 2017-08-25 02:37:23 UTC
proposed fix: https://gerrit.libreoffice.org/41546

This doesn't fix (b) footnote number isn't superscript.  That is because it isn't superscript by default in LibreOffice itself.
Comment 4 Commit Notification 2017-08-31 18:14:35 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c071e5f6858661881065cbb4e644c37c8e94ccc6

tdf#108765 DOCX: after import, allow default styles again

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Justin L 2017-09-04 18:43:28 UTC
requested backport to 5.4
Comment 6 Yousuf Philips (jay) 2017-09-05 09:27:57 UTC
(In reply to Justin L from comment #3)
> This doesn't fix (b) footnote number isn't superscript.  That is because it
> isn't superscript by default in LibreOffice itself.

LO doesnt default to use supserscript, but MSO does and that is what this bug is supposed accomplish, mimicking how it looks in MSO.
Comment 7 Yousuf Philips (jay) 2017-09-05 09:35:14 UTC
Created attachment 136026 [details]
MSO vs LO

Here is how an inserted footnote looks in MSO vs LO (with your latest patch).
Comment 8 Commit Notification 2017-09-05 14:28:10 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=adce43a12a9e9b3834e188ea0deb4af8d28a2d06&h=libreoffice-5-4

tdf#108765 DOCX: after import, allow default styles again

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2017-10-06 08:34:52 UTC
A polite ping to Justin Luth: is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 10 Justin L 2017-10-06 09:51:27 UTC
(In reply to Xisco Faulí from comment #9)
> A polite ping to Justin Luth: is this bug fixed? if so, could you please
> close it as RESOLVED FIXED ? Thanks

According to comment 6, this is not fixed.  "LO doesn't default to use supserscript, but MSO does and that is what this bug is supposed accomplish, mimicking how it looks in MSO."  I have already unassigned myself - it is still an open bug.