Bug 108781 - DOC password protection lost upon roundtrip ( if saved using the same document )
Summary: DOC password protection lost upon roundtrip ( if saved using the same document )
Status: RESOLVED DUPLICATE of bug 114221
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2017-06-26 01:41 UTC by Aron Budea
Modified: 2018-10-18 08:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Password protected DOC (22.50 KB, application/msword)
2017-06-26 01:41 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-06-26 01:41:21 UTC
Created attachment 134283 [details]
Password protected DOC

The attached document was created with Word 2013, and is protected with a password. Password is: 1234

Open document in Writer using the password, then save it.
Reopen document either in Writer or in Word.

=> Document is not protected with password anymore, and can be opened without one.

Observed using LO 5.4beta2 & 5.3.0.3 / Windows 7.
In 5.2.0.4 this kind of password protection is not yet supported for DOC files.
Comment 1 Aron Budea 2017-06-26 02:02:23 UTC
This is the commit that implemented import support:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=4f07175cd03bf0fa42992a06d51aed5b421adcf2
author		Caolán McNamara <caolanm@redhat.com>	2016-10-22 20:08:07 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2016-10-22 20:09:59 (GMT)

implement CryptoAPI RC4+SHA1 encryption scheme for doc import
Comment 2 Xisco Faulí 2017-06-26 11:11:42 UTC
The behaviour is somehow inconsistent.
If the file is saved with another name or in another folder, it's password protected after roundtrip. However, if it's saved using the same file, the protection is lost after roundtrip.

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 Marina Latini (SUSE) 2017-09-21 14:29:51 UTC
Could be a different bug but, when you try to open a password protected doc file generated by MS Office, LibreOffice opens it in read only mode without asking for the password.

Tested on:
Version: 6.0.0.0.alpha0+
Build ID: e0aed1459513be5e08fab9de06848df5dc9d0b5f
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-09-20_06:45:25
Locale: it-IT (it_IT); Calc: group
Comment 4 QA Administrators 2018-09-22 02:44:17 UTC Comment hidden (obsolete, spam)
Comment 5 Justin L 2018-10-18 08:16:53 UTC
Fixed in LO 5.4.5 by Caolán McNamara  2018-01-26 16:44:43 +0100
commit	2372003d94d3c58d90f6af524e916a2aa761cee2
Resolves: tdf#114221 generate both std97 and cryptoapi keys from password..

*** This bug has been marked as a duplicate of bug 114221 ***