Download it now!
Bug 108787 - Add a command line configuration option
Summary: Add a command line configuration option
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 108768 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-06-26 11:30 UTC by David Hedlund
Modified: 2017-11-15 10:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Hedlund 2017-06-26 11:30:17 UTC
dconf is a package used to configure GNOME settings from the terminal. Example, this will sort directories first in Nautilus:

dconf write /org/gnome/nautilus/preferences/sort-directories-first true

However, Libreoffice don't have any utilities to do that, but it should be easy to craft it because registrymodifications.xcu is very structured:

I use to set this setting for example:

<item oor:path="/org.openoffice.Office.Calc/Content/Display"><prop oor:name="ValueHighlighting" oor:op="fuse"><value>true</value></prop></item>
<item oor:path="/org.openoffice.Office.Calc/Input"><prop oor:name="AutoInput" oor:op="fuse"><value>false</value></prop></item>

Let's call the current missing option for --conf, it should look like this for my above setting example:

libreoffice --conf /org.openoffice.Office.Calc/Content/Display/ValueHighlighting true
libreoffice --conf /org.openoffice.Office.Calc/Input/AutoInput false
Comment 1 David Hedlund 2017-06-26 11:39:56 UTC
*** Bug 108768 has been marked as a duplicate of this bug. ***
Comment 2 Jean-Baptiste Faure 2017-07-30 17:17:38 UTC
Who need that instead of using Tools > Options > LibreOffice > Advanced > Open Expert Configuration ?

Please could you elaborate a bit on the usefulness of this enhancement for advanced users?

Set status to NEEDINFO, please set it back to UNCONFIRMED once requested
informations are provided.

Best regards. JBF
Comment 3 David Hedlund 2017-07-30 17:21:23 UTC
Its possible to build and run bash scripts with command line options to save time instead of using GUI.
Comment 4 Jean-Baptiste Faure 2017-07-30 17:37:22 UTC
(In reply to David Hedlund from comment #3)
> Its possible to build and run bash scripts with command line options to save
> time instead of using GUI.

I understand, but if you can write script, why not write directly registrymodifications.xcu ?

Best regards. JBF
Comment 5 David Hedlund 2017-07-30 17:39:13 UTC
Because that would not be safe enough, only command line options will modify registrymodifications.xcu properly and tell you if they fail to do so.
Comment 6 Xisco Faulí 2017-11-15 10:32:23 UTC
(In reply to Jean-Baptiste Faure from comment #4)
> (In reply to David Hedlund from comment #3)
> > Its possible to build and run bash scripts with command line options to save
> > time instead of using GUI.
> 
> I understand, but if you can write script, why not write directly
> registrymodifications.xcu ?
> 
> Best regards. JBF

I agree with Jean-Baptiste. You can either edit the config from the GUI or write registrymodifications.xcu directly.
@David, if you plan to work on this, move it to NEW, otherwise, moving it to RESOLVED WONTFIX