Bug 108859 - Context menu should offer the last used action
Summary: Context menu should offer the last used action
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Context-Menu Repeat
  Show dependency treegraph
 
Reported: 2017-06-29 12:04 UTC by Thomas Lendo
Modified: 2017-07-23 18:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2017-06-29 12:04:58 UTC
If you right-click in a text or text selection or cell or anywhere in the content area, then you should be offered to repeat/reuse the last used action you've done before.

This is an enhancement for the context menu that I know for example from Autodesk AutoCAD products. In the current version of AutoCAD there is no context menu anymore and the last action will be started with a right-click automatically.

In LibO, one of the first entries in the context menu should be "Repeat command" or something else, maybe followed by a short description of the command that will be started again ("Repeat: Text color" or "Repeat: Text color red").

If the last command has required further user action (e.g. inserting cells asks where it should be inserted and how existing cells should be shifted) then the user's selection should be reused so that no user action is needed anymore with the repeat command.

If the command that should be reused isn't available in the current selection or cursor position, then it should be grayed out and not available.

Ideally that should be available in all LibO components.
Comment 1 Heiko Tietze 2017-06-29 15:21:16 UTC
Wouldn't put 'Repeat' from the Edit menu into the contextual menu as it is cleared on context change. The shortcut shift+ctrl+Y is much faster, by the way.
Comment 2 Thomas Lendo 2017-07-06 10:49:35 UTC
I'll close this as WONTFIX since LibreOffice users aren't using right-click mouse menus other than for example AutoCAD users.

If a UX member thinks this is worth implementing it, please reopen the bug. :)