Bug 108926 - Notes placeholder text boxes not shown in PPTs
Summary: Notes placeholder text boxes not shown in PPTs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.0.0 target:5.4.2
Keywords: bibisected, bisected, filter:ppt, regression
Depends on:
Blocks: Notes-View
  Show dependency treegraph
 
Reported: 2017-07-03 12:53 UTC by Aron Budea
Modified: 2017-08-29 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPT (161.00 KB, application/vnd.ms-powerpoint)
2017-07-03 12:53 UTC, Aron Budea
Details
Original ODP of sample for reference (shows expected behavior) (10.86 KB, application/vnd.oasis.opendocument.presentation)
2017-07-03 12:55 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-07-03 12:53:41 UTC
Created attachment 134450 [details]
Sample PPT

Attaching a sample PPT, it has no notes, let's assume we want to add some.
Open it and switch to View -> Notes.

=> The expected text boxes with "Click to add Notes" are not there.

Observed with LO 5.4.0.1, 4.1.0.4 / Windows 7.
The text boxes are there in 4.0.0.3. => regression

Since the placeholders are there even when the PPT file is opened, it's not a FILESAVE issue (though the placeholder text appears vertically centered in the text box, and not at the top, as it would be expected).
Comment 1 Aron Budea 2017-07-03 12:55:04 UTC
Created attachment 134451 [details]
Original ODP of sample for reference (shows expected behavior)
Comment 2 Yousuf Philips (jay) 2017-07-03 13:38:58 UTC
Confirmed available in 4.0.6 and not available in master.

Version: 6.0.0.0.alpha0+
Build ID: 34c77d4bf3d2924c4ad26728d4c491b393fa0fc8
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 Aron Budea 2017-07-03 16:43:39 UTC Comment hidden (obsolete)
Comment 4 Aron Budea 2017-07-03 22:46:25 UTC
My previous guess is wrong, the regression is actually caused by this commit (verified by reverting):

https://cgit.freedesktop.org/libreoffice/core/commit/?id=acb2943c8125f4ceed74f35f31776929dedeb8d8
author		Jan Holesovsky <kendy@suse.cz>	2013-05-10 17:56:04 (GMT)
committer	Jan Holesovsky <kendy@suse.cz>	2013-05-12 16:05:57 (GMT)

"bnc#758621: We don't need this index for anything."

Previously in case of (eAktPageKind == PPT_NOTEPAGE), the code progressed further, now it only does if (eAktPageKind == PPT_SLIDEPAGE).
I'd submit a revert, but I wonder what the valid circumstances were where the code didn't enter the if-guarded section when it should've?
Comment 5 Aron Budea 2017-07-11 06:56:33 UTC
(In reply to Aron Budea from comment #0)
> Since the placeholders are there even when the PPT file is opened, it's not
> a FILESAVE issue (though the placeholder text appears vertically centered in
> the text box, and not at the top, as it would be expected).

I can't remember what I meant here... So if it's saved in a 4.1+ version and opened in 4.0.0.3, the text box with placesholder text is there, and the text is in the correct position.

With the commit reverted in master, the placeholder is there, but the text is vertically centered.
Comment 6 Aron Budea 2017-07-30 05:01:05 UTC
(In reply to Aron Budea from comment #5)
> With the commit reverted in master, the placeholder is there, but the text
> is vertically centered.

Reverting the commit breaks the original bugdoc in bnc#758621, though.
Comment 7 Commit Notification 2017-08-24 14:06:31 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b766cab621690a3aaf4e10fcf925ebab1c1925b8

tdf#108926: Notes placeholder text boxes not shown in PPTs

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-08-29 11:39:42 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b04a3245190844b07916481d73ed6d182593ed8&h=libreoffice-5-4

tdf#108926: Notes placeholder text boxes not shown in PPTs

It will be available in 5.4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.