Bug 108941 - UTF-8 .txt file opening gets accents corrupted
Summary: UTF-8 .txt file opening gets accents corrupted
Status: RESOLVED DUPLICATE of bug 60145
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Save-Text
  Show dependency treegraph
 
Reported: 2017-07-04 10:33 UTC by Marco A.G.Pinto
Modified: 2017-07-05 07:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
UTF-8 accents get corrupted (74 bytes, text/plain)
2017-07-04 10:33 UTC, Marco A.G.Pinto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2017-07-04 10:33:46 UTC
Created attachment 134475 [details]
UTF-8 accents get corrupted

I noticed the other day that opening a .txt with LO gets all accents corrupted.

See the sample file.

Thanks!
Comment 1 Buovjaga 2017-07-04 10:39:21 UTC
Confirmed. The file is UTF-8 without BOM, I checked in Notepad++

Win 7 Pro 64-bit Version: 6.0.0.0.alpha0+ (x64)
Build ID: a1ace08b5b86a76e7275dcef2545a7d52ae2ed2d
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-06-13_03:04:47
Locale: fi-FI (fi_FI); Calc: CL

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 m.a.riosv 2017-07-04 23:44:00 UTC
On the file type to open there is an option "Text - Choose encoding", that opens with a box to select the encoding.

I can't find but I think there is a reported bug about this matter.
Comment 3 Buovjaga 2017-07-05 07:49:54 UTC
I found a dupe.

*** This bug has been marked as a duplicate of bug 60145 ***