Bug 108956 - EDITING: LibO unresponsive after HTML paste
Summary: EDITING: LibO unresponsive after HTML paste
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: HTML-Paste
  Show dependency treegraph
 
Reported: 2017-07-04 19:23 UTC by Telesto
Modified: 2017-07-11 13:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2017-07-04 19:23:59 UTC
Description:
LibO unresponsive after HTML paste

Steps to Reproduce:
1. Open a random page (for example https://bugs.documentfoundation.org/show_bug.cgi?id=108867)
2. Select everything CTRL+A and copy CTRL+C (I copied it from Firefox)
3. Paste it intro writer (CTRL+V)

Actual Results:  
LibO doesn't respond anymore

Expected Results:
Should work like LibO5400rc1


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 6.0.0.0.alpha0+
Build ID: cac5c9f6081590b0548d3116bc4cd4a2509ec576
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-01_00:41:48
Locale: nl-NL (nl_NL); Calc: CL

but not with
Versie: 5.4.0.1 
Build ID: 962a9c4e2f56d1dbdd354b1becda28edd471f4f2
CPU-threads: 4; Besturingssysteem:Windows 6.2; UI-render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Xisco Faulí 2017-07-05 10:45:10 UTC
Reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 08f6f9dded1b142b858c455da03319abac691655
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.16.10.1~lo0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Xisco Faulí 2017-07-05 11:07:39 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-06-16 06:35:05 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-06-16 10:58:38 (GMT)
commit 6ade80cf142664e78954c7544534e9436ceb90c7 (patch)
tree 1067e9c880fc6a68eed2a18368bfe94a892522e4
parent 559b641b3ff3500547bf7c79741e1e5b4414d404 (diff)
tdf#108524 sw: allow move of frame inside section without columns
The intention here is to deny the move of a frame that's inside a table
inside a section.  But the code also checked if there a column frame
in-between, so it allowed the move for a frame in a section with 2 cols,
but not without columns (which does not sound intentional, since that's
a simpler case). So drop the requirement to have a column frame between
the argument and the section frame, just check that there is no table
frame in between.

This is needed, but not enough to split the section in the bugdoc (but
at least now the content of the section is marked as movable).

Bisected with bibisect-linux64-6.0

Adding Cc: to Miklos Vajna
Comment 3 Miklos Vajna 2017-07-11 12:39:38 UTC
Hmm, I can't reproduce.

To be as close to Xisco as possible I did:

1) git clone git://gerrit.libreoffice.org/bibisect-linux-64-6.0
2) git checkout afe81c644cf9d368884b60bbe8f2e3049bc3f7a7
3) LC_ALL=ca_ES.UTF-8 instdir/program/soffice

And still when I copy&paste https://bugs.documentfoundation.org/show_bug.cgi?id=108867 from firefox (52.2.0) to LO Writer, it's not freezing here.

Xisco, I had a couple of follow-up commits since then in this area, could you please check if the latest bibisect-linux-64-6.0 version is still affected?

Other than that, any ideas on how can I reproduce this is welcome. Thanks!
Comment 4 Miklos Vajna 2017-07-11 12:43:23 UTC
One idea: can you save the HTML page as you see it, and attach it? The bug page is a bit different depending on if you are logged in, what are your preferences, just in case that counts.
Comment 5 Xisco Faulí 2017-07-11 12:45:50 UTC
Hi Miklos,
it seems to be fixed in

Version: 6.0.0.0.alpha0+
Build ID: ddadcb4f4a2bc6538c219a0a577bdf5999015150
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

(latest build from bibisect-linux64-6.0)

So it seems it's been fixed in the last week. I guess we can close it as RESOLVED WORKSFORME
Comment 6 Xisco Faulí 2017-07-11 12:59:12 UTC
Fixed by

author	Miklos Vajna <vmiklos@collabora.co.uk>	2017-07-06 12:07:45 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2017-07-06 19:18:27 (GMT)
commit 972fbddf80510f7daaf2128dbfda01c0e7535020 (patch)
tree 48c0b4c404509df31649224073bb789197666cd3
parent 2de270e4fd0ab96691b251b38caf71b3fc87574d (diff)
i#61225 sw: fix layout loop with growable single-column sections
Comment 7 Miklos Vajna 2017-07-11 12:59:45 UTC
Thanks, that was quick. :-)
Comment 8 Xisco Faulí 2017-07-11 13:01:35 UTC
you were even quicker fixing it :D