Download it now!
Bug 108969 - Saving should warn about losing signatures
Summary: Saving should warn about losing signatures
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2017-07-05 12:30 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2017-12-04 15:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2017-07-05 12:30:34 UTC
When you save a document which is digitally signed, all signatures are removed.

The user should be warned in such a case, because he can destroy all signatures by simply hitting Ctrl-S.
Comment 1 Samuel Mehrbrodt (allotropia) 2017-07-24 11:59:31 UTC
So this works in 5.3.1.2, but not in 5.4.0.3.
But again, it works in current master (July 17th, d7ac239793905564d2754edc52611930b6ba2cdc)
Comment 2 Xisco Faulí 2017-12-04 14:20:21 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #1)
> So this works in 5.3.1.2, but not in 5.4.0.3.
> But again, it works in current master (July 17th,
> d7ac239793905564d2754edc52611930b6ba2cdc)

Hi Samuel,
Should it be closed then?
Comment 3 Samuel Mehrbrodt (allotropia) 2017-12-04 14:29:06 UTC
(In reply to Xisco Faulí from comment #2)
> Should it be closed then?

I'd leave it open as long as 5.4 is still supported.
Comment 4 Xisco Faulí 2017-12-04 14:31:04 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> (In reply to Xisco Faulí from comment #2)
> > Should it be closed then?
> 
> I'd leave it open as long as 5.4 is still supported.

If you share a document where i can reproduce the issue, I can find at which point the issue was fixed in order to backport it to 5.4
Comment 5 Samuel Mehrbrodt (allotropia) 2017-12-04 14:35:36 UTC
(In reply to Xisco Faulí from comment #4)
> If you share a document where i can reproduce the issue, I can find at which
> point the issue was fixed in order to backport it to 5.4

You can try with attachment 134903 [details] (any signed doc should work).
Comment 6 Xisco Faulí 2017-12-04 14:59:00 UTC
I can't reproduce it in

Version: 6.1.0.0.alpha0+
Build ID: 2618e4a13d719122e6358d9d96864d1691e56a02
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: th-TH (ca_ES.UTF-8); Calc: group threaded

nor in

Version: 5.4.3.2
Build ID: 1:5.4.3~rc2-0ubuntu0.17.04.1~lo1
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: es-ES (ca_ES.UTF-8); Calc: group

nor in

Version: 5.3.0.0.alpha1+
Build ID: 4136757b4e51c4e6f7cb4132c95538a7f831ef2c
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ar-DZ (ca_ES.UTF-8); Calc: group

Can you reproduce it in 5.4.3.2?
Comment 7 Samuel Mehrbrodt (allotropia) 2017-12-04 15:21:49 UTC
Ok, lets close it then, thanks for testing!
Maybe the issue has been fixed in the meantime.