Bug 109027 - User has to look for CSV file-open dialog, rather than dialog popping up
Summary: User has to look for CSV file-open dialog, rather than dialog popping up
Status: RESOLVED DUPLICATE of bug 32935
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-08 20:49 UTC by Assaf
Modified: 2017-07-15 13:47 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Assaf 2017-07-08 20:49:35 UTC
Hi,

This is a long-standing LO annoyance, I just realized it should be a reportable bug.

When opening a .csv file, if any LO file is already open, what one sees is the "wait/timepiece" symbol of the operating system, rather than the .csv opening dialog (the one that asks you what separator to use, etc.).

Even worse, the dialog will be hiding in what appears to be a random file. Even if you have Calc open, it might show up in a Writer file, Impress file, etc. Apparently the rule is that it's the most recent file opened, or the most recent visited. Either way, if you have several files open it's a huge annoyance and novice users won't have any idea what happened to their .csv file.

Actually, I wonder whether the .csv open behavior can be tweaked to not have a dialog at all upon a file double-click, unless LO encounters some discrepancy. CSV by definition is comma-separated, so LO can simply assume that and open it using default options. 
Conversely, when opening from within LO, the dialog should still pop up. But it must pop up on top, rather than tucked away in some random file.

Thanks, Assaf
Comment 1 Adolfo Jayme 2017-07-15 13:47:20 UTC
Thanks for your report! This issue has been reported already, so I’ll mark your report as a duplicate.

*** This bug has been marked as a duplicate of bug 32935 ***