Bug 109050 - Moving table object with ALT+Arrow keys does not work properly
Summary: Moving table object with ALT+Arrow keys does not work properly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
QA Contact:
URL:
Whiteboard: target:6.0.0 target:5.3.5 target:5.4.1
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-10 10:47 UTC by Tamás Zolnai
Modified: 2017-08-17 08:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2017-07-10 10:47:02 UTC
Description:
ALT + Arrow Keys shortcut is used to move objects (shapes, images, tables, etc.) with one pixel. In Impress, when trying to use this short cut on tables, only the left and right direction works, but the up and down directions are not. This short code should work with all arrow keys.

Steps to Reproduce:
1. Open Impress
2. Insert a table
3. Click in any cell and after that select the whole table with clicking on its contur
4. Check how ALT + arrow keys shortcut works

Actual Results:  
Shortcut works as expected on left and right direction, but does not work for up and down direction. When pressing ALT + up and down table step into editing mode and cursor appears in one of the cells.

Expected Results:
ALT + up/down should move the object.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 Xisco Faulí 2017-07-11 14:49:02 UTC
Moving to ASSIGNED since there's a patch in gerrit: https://gerrit.libreoffice.org/#/c/39810/
Comment 2 Commit Notification 2017-07-11 19:19:51 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5637ae74ad6bb517255510a8ae786fd2a3cf977

tdf#109050: Moving table object with ALT+Arrow keys does not work properly

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2017-07-12 18:25:26 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1308ee8106da02d0f287ef5d77ff970bb65a72fa&h=libreoffice-5-3

tdf#109050: Moving table object with ALT+Arrow keys does not work properly

It will be available in 5.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-07-14 06:43:52 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=73ea880fe1a21af5233b1cbb91618b568b760d8b&h=libreoffice-5-4

tdf#109050: Moving table object with ALT+Arrow keys does not work properly

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Cor Nouws 2017-08-17 08:02:57 UTC
OK in Version: 6.0.0.0.alpha0+
Build ID: 75933b220d48bceff25b07cfc4b55c70a2e24917
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-16_22:50:24
Locale: nl-NL (nl_NL.UTF-8); Calc: group

thanks Tamás!