Download it now!
Bug 109134 - Many fields were missing after saving XLSX
Summary: Many fields were missing after saving XLSX
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields XLSX
  Show dependency treegraph
 
Reported: 2017-07-15 10:23 UTC by jonatan@autistici.org
Modified: 2017-09-15 19:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with missing fields (9.94 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-07-15 13:48 UTC, jonatan@autistici.org
Details
Original ODF file (12.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-07-15 13:50 UTC, jonatan@autistici.org
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonatan@autistici.org 2017-07-15 10:23:55 UTC
I just lost a lot of fields with text after saving and re-opening my XLSX file.
Comment 1 jonatan@autistici.org 2017-07-15 12:29:49 UTC
The fields seem to have been randomly removed
Comment 2 Xisco Faulí 2017-07-15 13:29:10 UTC Comment hidden (obsolete)
Comment 3 jonatan@autistici.org 2017-07-15 13:48:29 UTC
Created attachment 134648 [details]
Document with missing fields

Here is the document, many fields in A, E, H, I and K columns are missing. I know that I saved it before several times before I opened it so many of the fields should be there. 

I made the XLSX file from an ODT file and then continued to work on it and then I had it open for several days working on it and saving it several times.
Comment 4 jonatan@autistici.org 2017-07-15 13:50:46 UTC
Created attachment 134649 [details]
Original ODF file

Here is the ODT file that I converted from
Comment 5 Xisco Faulí 2017-07-15 14:26:16 UTC
I can't reproduce it in

Version: 5.3.4.2
Build ID: 1:5.3.4-0ubuntu0.16.10.1~lo0.1
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.