Download it now!
Bug 109151 - Undo actions are not grouped when deleting with Track Changes set
Summary: Undo actions are not grouped when deleting with Track Changes set
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks: Track-Changes Undo-Redo
  Show dependency treegraph
 
Reported: 2017-07-17 04:40 UTC by Rosemary Sebastian
Modified: 2019-06-04 22:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test with LO 3.3 (221.92 KB, application/pdf)
2017-07-26 08:11 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rosemary Sebastian 2017-07-17 04:40:42 UTC
Description:
If Track Changes is set, deleting a word by continuous backspaces or deletes, results in separate undo actions for each letter.

Steps to Reproduce:
1. Open a Writer document.
2. Insert a word or a few words, say "Hello World".
3. Turn on Track Changes
4. Delete a word, say "World", by hitting Backspace for each letter.
5. Now pressing Ctrl-Z only restores the last letter, in this case, "W", instead of the whole word.

Actual Results:  
A new undo action is added for each letter.

Expected Results:
The undo actions should be grouped to form a single undo action.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36
Comment 1 Timur 2017-07-25 10:02:52 UTC
Since you changed to Assigned and confirmed the bug yourself, I change back to Needinfo. 
Why do you think it's a bug? 
If we delete letter by letter, then Undo restores letter by letter. 
If we delete word by word, then Undo restores word by word. 
Looks logical. MSO works the same.
Comment 2 Rosemary Sebastian 2017-07-25 12:20:17 UTC
So I set the importance as "medium enhancement". Does that solve the problem?
Comment 3 Timur 2017-07-25 17:37:04 UTC
It's not importance that was my question, but why do you think that actual results are wrong. 
On a second thought, you may be right. There's a single reject action and undo action could be single. As it was before like in OO and LO 3.3, looks like regression all the way from 3.4. 
I set back to Assigned.
Comment 4 Rosemary Sebastian 2017-07-26 07:35:11 UTC
This bug report is about using the same grouping mechanism for delete undo actions irrespective of whether Track Changes is set or not set. Are you sure this is a regression?
Comment 5 Timur 2017-07-26 08:11:33 UTC
Created attachment 134864 [details]
Test with LO 3.3

Looks like regression because it worked as expected with OO and LO 3.3, as attached.
Comment 6 Rosemary Sebastian 2017-07-28 07:25:04 UTC Comment hidden (obsolete)
Comment 7 Rosemary Sebastian 2017-08-02 08:06:30 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2018-08-19 02:37:14 UTC Comment hidden (obsolete)
Comment 9 Aron Budea 2019-06-04 22:46:21 UTC
Seems to work as expected now, closing as WFM.

Version: 6.3.0.0.alpha1+
Build ID: 1376bb3e44c4b9eb15cf788df04f7cc0bba8cb09
CPU threads: 16; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded