Bug Hunting Session
Bug 109187 - FILEOPEN PPTX: Flipped gradients have wrong angle
Summary: FILEOPEN PPTX: Flipped gradients have wrong angle
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Paul Trojahn
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-18 10:45 UTC by Paul Trojahn
Modified: 2017-08-30 18:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example presentation (30.14 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-07-18 10:48 UTC, Paul Trojahn
Details
Presentation in PowerPoint (10.77 KB, image/png)
2017-07-18 10:49 UTC, Paul Trojahn
Details
Presentation in Impress (14.49 KB, image/png)
2017-07-18 10:49 UTC, Paul Trojahn
Details
Test file sd/qa/unit/data/n762695.pptx in PowerPoint (39.11 KB, image/png)
2017-07-18 10:57 UTC, Paul Trojahn
Details
Test file sd/qa/unit/data/n762695.pptx in Impress (18.93 KB, image/png)
2017-07-18 10:58 UTC, Paul Trojahn
Details
still incorrect gradients of shapes in Daily20170816 (88.76 KB, image/png)
2017-08-17 07:42 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Trojahn 2017-07-18 10:45:23 UTC
Description:
The gradients of flipped shapes get imported incorrectly.

Steps to Reproduce:
1.Create a shape in PowerPoint.
2.Set a gradient as background.
3.Flip and rotate the shape.
4.Open in Impress.

Actual Results:  
The angle of the gradient is different.

Expected Results:
It should be the same.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Comment 1 Paul Trojahn 2017-07-18 10:48:36 UTC
Created attachment 134706 [details]
Example presentation
Comment 2 Paul Trojahn 2017-07-18 10:49:23 UTC
Created attachment 134707 [details]
Presentation in PowerPoint
Comment 3 Paul Trojahn 2017-07-18 10:49:59 UTC
Created attachment 134708 [details]
Presentation in Impress
Comment 4 Paul Trojahn 2017-07-18 10:57:56 UTC
Created attachment 134709 [details]
Test file sd/qa/unit/data/n762695.pptx in PowerPoint
Comment 5 Paul Trojahn 2017-07-18 10:58:56 UTC
Created attachment 134710 [details]
Test file sd/qa/unit/data/n762695.pptx in Impress
Comment 6 Xisco Faulí 2017-07-19 08:53:27 UTC
Confirmed in

Version: 6.0.0.0.alpha0+
Build ID: ddadcb4f4a2bc6538c219a0a577bdf5999015150
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 7 Commit Notification 2017-08-10 15:51:42 UTC
Paul Trojahn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5fc980154a968d8f48803289f0042d105dfc102a

tdf#109187 Fix OOXML import of flipped shapes with gradients

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Cor Nouws 2017-08-17 07:42:45 UTC
Created attachment 135606 [details]
still incorrect gradients of shapes in Daily20170816

tested in Version: 6.0.0.0.alpha0+
Build ID: 75933b220d48bceff25b07cfc4b55c70a2e24917
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-16_22:50:24
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 9 Cor Nouws 2017-08-17 07:43:38 UTC
Hi Paul - for me this still is the same as in your attachment 134708 [details]
Comment 10 Paul Trojahn 2017-08-24 22:35:07 UTC
The arrows look slightly different from the PowerPoint screenshot because LibreOffice starts the gradient at the edge of the bounding box and not at the shape. This bug was only intended to cover the incorrect angle of the gradient.
Comment 11 Cor Nouws 2017-08-25 06:52:36 UTC
thanks for explaining Paul!
Comment 12 Xisco Faulí 2017-08-30 18:28:57 UTC
Could you please report it in a follow-up bug?